Battery keeps draining Gen 2

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

smurfslayer

Be vewwy, vewwy quiet. We’re hunting sasquatch77
Joined
Dec 16, 2016
Posts
16,454
Reaction score
24,323
Don't know if you've seen this. I have the same problem, waking up to a dead battery.


Same problem as you.

Apparently I got a lemon. Started with water in the frame back in 2018 (got the interior carpet wet / moldy - was a total mess), that was the only thing they covered under warranty. Then came random turn signal issue, ended up having to replace entire mirror assembly ($500, I think). Panaromic roof - grinding / snapping / stopped operating. They had to replace the thing (iirc $1k).. the list goes on.

Going to get it up to *****, and sell it. Never buying another Ford.
2018 Raptor?
I’ll give you $1500 for it.
 

New recaros

FRF Addict
Joined
May 23, 2019
Posts
2,574
Reaction score
3,910
Location
Colorado
This sucks, with my tail between my legs, my truck was dead today. 11.4 volts, would not start. I got it started after using a charger, took to Ford they said the battery was good. Nothing was wrong. When I got home, I noticed the light in the little cubby under the radio was on and a light under the rear air cond vents. Can’t seem to shut them off, three hours later, they are still on. Put on the charger for the night. Damm it
 

FordTechOne

FRF Addict
Joined
Jul 29, 2019
Posts
6,470
Reaction score
12,653
Location
Detroit
This sucks, with my tail between my legs, my truck was dead today. 11.4 volts, would not start. I got it started after using a charger, took to Ford they said the battery was good. Nothing was wrong. When I got home, I noticed the light in the little cubby under the radio was on and a light under the rear air cond vents. Can’t seem to shut them off, three hours later, they are still on. Put on the charger for the night. Damm it
Do you have any ForScan mods?
 

smurfslayer

Be vewwy, vewwy quiet. We’re hunting sasquatch77
Joined
Dec 16, 2016
Posts
16,454
Reaction score
24,323
Is there an easy way to fix it ? If that's the case or try?
This is why you make FORSCAN modes 1x1, carefully and assess. I realize it’s easy and fun to keep up with the “cool kids” who install 15 FORSCAN mods all at once without even thinking about an “as is” backup, but don’t !

You can either walk back your changes manually, or restore from a FORSCAN backup. if you don’t know the original values, you can get the “as built” values from one of the Ford websites - I don’t recall the site - maybe another FRF can offer a friendly link ?

The one I’m most used to reading about here, is mucking about with the DRL settings. That one seems to contribute to quite a few weird problems.

I made a couple mistakes early on, one was with putting the heated wheel, and the heated / cooled seats icons on the sync home page. That one I entered the wrong table entry and forgot the steering wheel - which was kind of the reason for the exercise in the first place. The other was Lincoln fold mirrors. That one was a typo, the change just didn’t work, so I reverted back and did the mod again from scratch. That worked.

The changes where you have multiple modules involved can be the most challenging.

I know the Jen Too page has a couple mods that disable batter management (BMS). One is the aftermarket subwoofer mod - which turns off auto stop/start.
 
Top