Replaced stock sub BO unleashed issues

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Ckhris

Full Access Member
Joined
Dec 18, 2016
Posts
141
Reaction score
66
I installed a Kicker 46CXA 400.1
Kicker keyloc
Kicker CVTDF102 10” sub
Soundsgoodstereo amp connector plug

When I unplugged the stock sub and started mounting everything but nothing plugged into stock yet… I had to run to hardware store and get some bolts and a cover for the hole where the stock sub was. I noticed the stereo sound was lower at the levels I used to listen too… before level 20 was pretty loud… 15 was not loud and 20 wasnt either… figured once the system was in and up and running the volume level would be back but it was not… I tried adjusting the fade and balance and no mater where I moved the dot noting changed. Im thinking I need to do something with forscan and have googled it but I have not found anything that states… yep I had this and this is what I did to fix it.
 
Last edited:

HighwaySentinel

︻デ┳═ー - - - - - - -
Joined
Dec 13, 2020
Posts
1,522
Reaction score
3,322
Location
California
So, you took out the stock amp and subwoofer and all you did was put an aftermarket amp and sub and the keyloc dsp? That will not work. You need the zen navtv or equivalent to do it right.
 

The Car Stereo Company

aka grumpy car stereo guy
Supporting Member
Joined
Jul 8, 2012
Posts
31,730
Reaction score
21,722
Location
here, on frf
if the oem amp is gone, then its going to sound crappy (er) there are other speakers that are not controlled by the oem amp and thats what you are hearing. namely the center channel speaker, tweeters and rear speakers are controlled from the head unit
 
OP
OP
C

Ckhris

Full Access Member
Joined
Dec 18, 2016
Posts
141
Reaction score
66
OEM amp is still there
Everything is still there minus the stock sub
 

Shane361

FRF Addict
Joined
Aug 3, 2021
Posts
1,538
Reaction score
2,881
Location
Charleston, SC
This will fix it...
Remove all mids and highs, sound deaden, block off plates etc etc
Replace all mids and highs with aftermarket
Add Nav interface and whatever new equivalent
Add mono amp for subs
Add 4 channel for mids and highs
Add subs and enclosure, behind seat, underseat, remove seat, blow through...done them all.
Add Sound Processor if desired..tune tune tune, gain is not a volume knob etc etc
Replace Alternator with bigger and better
Add Lithium if your amp needs more electrical etc etc etc

Oh look you have spent >10 grand.

HAHAHAHAHAHAHA...but it will fix it will it not? LOL
 
Top