Help Support Ford Raptor Forum by donating:


Gen1 2014 Phoenix Android Radio upgrade thread.

Discussion in 'Ford Raptor Audio/Video/Electronics Forum [GEN 1]' started by dirtaddicted, May 29, 2019.

  1. Stricken

    Stricken Member

    Posts:
    43
    Likes Received:
    30
    Joined:
    Sep 29, 2018
    Location:
    Vail, Az
    Just wondering if anyone else has tried an updated version of this radio with better results? It would be cost effective and really slick to have the nav setup built into the truck (like Ford should have done from the start), but obviously not if it causes other issues.

    I see Phoenix currently has several open box units for sale which is ominous....
     
  2. spatel

    spatel Member

    Posts:
    2
    Likes Received:
    1
    Joined:
    Jul 16, 2012
    Greetings everybody--I have a Gen 1 2012 and I just ordered the PX6 8.1 Android radio from Phoenix--I can say it works FLAWLESSLY (after getting all the settings right). I found a local car audio guy who had never installed one of these before and he did a great job (I can point anybody in the Houston area to him if needed). My only feature that is not working is my backup camera, which needs an additional harness which I have contacted Phoenix about. I can't tell you how awesome this thing is--I now have Amazon Music, DI.FM (European EDM radio), YouTube, Netflix (APK install), AT&T Uverse (yes, full 500+ channels in my truck), and full screen Google Maps all working. Additionally, Android Auto works great too, though the whole point of having this is it working on its own. I find the Android Auto feature useless--and it doesn't take advantage of the full screen. You really have to know your way around Android to get this thing working--I can safely report though that my wife can navigate this intuitively at this point and it works as if it was a factory device. I can piggyback it off a hotspot or off my phone as a hotspot. You can also download Amazon music and Google Maps such that you don't need any data connection (I do this for quick short trips). Entire Houston metro is only 300 mb for Google Maps. The streaming services obviously need an active internet source. Netflix did not appear in Google Play store, so you have to download the APK off a third party site and manually install it (the radio is obviously rooted). For Netflix, only the pause/play and forward/reverse 10 secs works--you cannot manually drag to a desired spot in the entire video--kind of annoying, but I don't plan on using Netflix much. The AT&T Uverse app, YouTube, and Amazon Music apps work perfectly. For those that have non-streaming music, you can load those files onto the device or play off USB stick--for those the forward/reverse features off the steering wheel works. For Amazon music, they do not--volume works though for all apps. HVAC controls all work too--only caveat is the heated/cooled seats don't show the level (1-3) so you have to count how many times you touched the button--not a big deal. The rest of the AC controls all work and are very intuitive. The response of the device is extremely instant and there are no delays for me whatsoever. This thing looks, feels, and acts like a factory system with very few minor quirks that most people won't care about. As was noted on the Gen 2 thread (which is FULL of good info), using Nova launcher makes it even easier and more slick. Sorry for the random stream of thoughts--hope this helps others who are on the fence--I'll report back on the backup camera. Happy to answer questions if needed. // SGP
     
    NMBoondocker likes this.
  3. NMBoondocker

    NMBoondocker Member

    Posts:
    4
    Likes Received:
    0
    Joined:
    May 15, 2019
    Location:
    Los Alamos, NM
    spatel - thanks for the updated info. This is good info for those of us with 2012 and older. Please keep us updated with how you like the system and whether you run into any issues.
     
  4. iateajeep78

    iateajeep78 Member

    Posts:
    9
    Likes Received:
    2
    Joined:
    Apr 22, 2014

    I tried this out. Purchased the latest and greatest for my ‘13 Gen 1, and received unit on 10/21/19.

    My issues:
    1 - too much glare from daylight. I have all windows tinted at 30%. Front window is 50%.
    2 - back up camera connection, I had to wire up myself into their supplied harness. Sketchy video quality at best. Guide lines did nit line up.
    3 - ordered built-in Carplay option. Never worked. Tried reinstalling the apk several times. Was only able to use through oem usb inputs, not the supplied usb cable that I had to run through the glove box. Tech support had to contact China for a resolution...? Never did get it resolved.
    4 - wifi would not stay connected to multiple devices. Kept dropping devices into “saved” folder, and would not maintain.
    5 - radio reception suddenly was terrible.
    6 - was told to do a factory reset using a file provided through dropbox. After install, unit was essentially a pretty screen. Touch controls did not work, so I had no access to any settings.

    I will try to post photos/video clips from fb messenger of my interactions with Phoenix when I have more time.

    Really wanted this to work, but it it getting shipped back today.



    Sent from my iPhone using Tapatalk
     
    Stricken and NMBoondocker like this.
  5. Stricken

    Stricken Member

    Posts:
    43
    Likes Received:
    30
    Joined:
    Sep 29, 2018
    Location:
    Vail, Az

    Thank for the feedback. Unfortunate as this really would offer a lot of options. I'll keep running my tablet on a Ram Mount for now.
     

Share This Page