Battery issue, Charging issue or BMS issue?

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

OP
OP
Raptorbert

Raptorbert

Full Access Member
Joined
Jul 17, 2022
Posts
356
Reaction score
194
Location
Hampshire, IL
Anyone have a specific link to this H8 battery? I'm a fan of NorthStar or the Xtreme2 (same thing, different brand) though I haven't looked. This is a lazy post. I'll search this afternoon for H8s.

Couldn't wait. I might pick this up today. Have had two different models of these X2Power branded batteries with awesome results.

Looking at the one picture above in this thread, looks like this one is down on CCA and capacity from even factory. Hmm. More research this afternoon.
I haven’t seen an H8 from that manufacturer
 

swoop1156

FRF Addict
Joined
Dec 14, 2010
Posts
3,757
Reaction score
731
Location
USA
I haven’t seen an H8 from that manufacturer
Yeah, the search function on the Batteries Plus website showed me the Group 48 battery under those search results for the Group 49. This is why I wait till afternoon to engage my brain.

Locally I have the Duracell SLI49AGM, built by Deka - probably gonna snag that. I'm literally standing in front of it right now.
 

Attachments

  • 17089589369768445943775986800984.jpg
    17089589369768445943775986800984.jpg
    144.3 KB · Views: 12
OP
OP
Raptorbert

Raptorbert

Full Access Member
Joined
Jul 17, 2022
Posts
356
Reaction score
194
Location
Hampshire, IL
Yeah, the search function on the Batteries Plus website showed me the Group 48 battery under those search results for the Group 49. This is why I wait till afternoon to engage my brain.

Locally I have the Duracell SLI49AGM, built by Deka - probably gonna snag that. I'm literally standing in front of it right now.
Hell ya. Hopefully that fixes your problems. I’ve been monitoring mine and I’m getting about 5% SoC drain in 24hrs. I feel like that’s normal and I’m even seeing the truck reach 80% (ford BMS set limit) within 45 minutes of driving which I haven’t seen routinely with my motorcraft battery.
 

swoop1156

FRF Addict
Joined
Dec 14, 2010
Posts
3,757
Reaction score
731
Location
USA
Hell ya. Hopefully that fixes your problems. I’ve been monitoring mine and I’m getting about 5% SoC drain in 24hrs. I feel like that’s normal and I’m even seeing the truck reach 80% (ford BMS set limit) within 45 minutes of driving which I haven’t seen routinely with my motorcraft battery.
Tossed that biggun up in there. Fit with a tad bit of room to spare, lengthwise, as well. No clearance issues. Blanket went around too, nice and snug.

Went to batteries plus, and they knocked off $20 cuz Sam's had a "similar" model from Duracell but not the same, so they met me in the middle. Had them bench test it before I bought it. Showed 83% SoC, and registered 1,088 cranking amps at room temperature.

Then to my surprise, Amex had an offer on their Platinum card I used which gave me a whole whopper of 5% back. Sweet!

I'll be sure to report back by at least the weekend when it sits and only looks pretty and does no duty. I get to drive the V8TT on weekends instead of the widdle V6TT

Pics because do you know me? Always pics!
 

Attachments

  • PXL_20240226_152404072.jpg
    PXL_20240226_152404072.jpg
    179.3 KB · Views: 25
  • PXL_20240226_153704819.PORTRAIT.jpg
    PXL_20240226_153704819.PORTRAIT.jpg
    197 KB · Views: 25
  • PXL_20240226_152419268.jpg
    PXL_20240226_152419268.jpg
    171 KB · Views: 26
  • PXL_20240226_152410327.jpg
    PXL_20240226_152410327.jpg
    187.7 KB · Views: 24

swoop1156

FRF Addict
Joined
Dec 14, 2010
Posts
3,757
Reaction score
731
Location
USA
Some things I've noticed since I replaced the battery yesterday and did a BMS reset:

  1. The shifter is more grabby/catchy. I like it, it feels like it's solidly in gear/park/neutral. Not sure if this is at all related.
  2. The truck turns over faster and starts quicker.
  3. I'm getting OTA updates out of the ***** suddenly. (I cannot say WAZO0 but I can say shit? lol)
  4. Android Auto still doesn't work for shit.
 
OP
OP
Raptorbert

Raptorbert

Full Access Member
Joined
Jul 17, 2022
Posts
356
Reaction score
194
Location
Hampshire, IL
Some things I've noticed since I replaced the battery yesterday and did a BMS reset:

  1. The shifter is more grabby/catchy. I like it, it feels like it's solidly in gear/park/neutral. Not sure if this is at all related.
  2. The truck turns over faster and starts quicker.
  3. I'm getting OTA updates out of the ***** suddenly. (I cannot say WAZO0 but I can say shit? lol)
  4. Android Auto still doesn't work for shit.
Just the OTA updates are huge!
 

swoop1156

FRF Addict
Joined
Dec 14, 2010
Posts
3,757
Reaction score
731
Location
USA
Just the OTA updates are huge!
My garage interior camera keeps alerting me that there's a vehicle detected. I reviewed the footage cuz it was getting ridiculous and my truck is in there flashing it's lights and making clicking noises and having a party all itself
 

swoop1156

FRF Addict
Joined
Dec 14, 2010
Posts
3,757
Reaction score
731
Location
USA
Welp, I have fairly high confidence that what I felt (and everyone here thought), and the dealer said no way, has been solved as a battery being stupid.

I replaced my factory AGM with the new Duracell as posted above and I've not had one problem, FordPass notification, the truck is awake and alert when I'm nearby, the lights work, everything is as it should be.

Replace the battery folks. It starts faster and seems Android Auto has un-jacked itself for the most part as well.

It sat all weekend and never had an issue like I would have every single other weekend.
 
OP
OP
Raptorbert

Raptorbert

Full Access Member
Joined
Jul 17, 2022
Posts
356
Reaction score
194
Location
Hampshire, IL
Welp, I have fairly high confidence that what I felt (and everyone here thought), and the dealer said no way, has been solved as a battery being stupid.

I replaced my factory AGM with the new Duracell as posted above and I've not had one problem, FordPass notification, the truck is awake and alert when I'm nearby, the lights work, everything is as it should be.

Replace the battery folks. It starts faster and seems Android Auto has un-jacked itself for the most part as well.

It sat all weekend and never had an issue like I would have every single other weekend.
I JUST got done swapping back and forth with the new battery and the only few month old problematic motorcraft battery. the motorcraft NEVER had stop start engage, saying "charging" as the reason on the dash. It was charging at 13.5V so im assuming low SOC. went back to my new H8 and immediately everything was working again. im sold on the rotorcraft having a problem.
 

EricM

FRF Addict
Joined
May 11, 2016
Posts
3,176
Reaction score
2,658
Location
OHIO
You guys tried to unplug the BMS sensor and see how the truck charges? It may revert to charging like you would expect a vechile to.
 
Top