Terribly loud boom and white noise

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Jimandaim

Member
Joined
Sep 21, 2023
Posts
2
Reaction score
0
Location
Penna.
Welll....at the suggested post to have update on my 22 , to fix the loud boom and hiss.....update was done......dealer wants to hear it......never happens there at dealer...go figure.....
Still does after update...
.try to capture on recorder......but u know how that works!!!!!
Any more suggestions??????
Open to anything.....I do know others have had this with B&O 18 spkr system....
 

smurfslayer

Be vewwy, vewwy quiet. We’re hunting sasquatch77
Joined
Dec 16, 2016
Posts
16,279
Reaction score
23,977
Welll....at the suggested post to have update on my 22 , to fix the loud boom and hiss.....update was done......dealer wants to hear it......never happens there at dealer...go figure.....
Still does after update...
.try to capture on recorder......but u know how that works!!!!!
Any more suggestions??????
Open to anything.....I do know others have had this with B&O 18 spkr system....
Welcome to FRF, N00b.

Pictures, or it’s a prius.

Hang a go pro from the windshield if you don’t already have one. Power it with a tap from the roof console wiring, and adapter to mini or micro usb - whatever port that is.
Drive while recording. When it happens, stop the recording to save it and start a new one. If you run out of space while recording, sometimes it corrupts the file.

Download and take to the stealership.
 

HighwaySentinel

︻デ┳═ー - - - - - - -
Joined
Dec 13, 2020
Posts
1,522
Reaction score
3,322
Location
California
It looks like you have had the update done. Have you checked all of your fuses to make sure they are seated. The fuse for the amp can be a cause. Also, how's your battery?
 

smurfslayer

Be vewwy, vewwy quiet. We’re hunting sasquatch77
Joined
Dec 16, 2016
Posts
16,279
Reaction score
23,977
It looks like you have had the update done. Have you checked all of your fuses to make sure they are seated. The fuse for the amp can be a cause. Also, how's your battery?
is that where the boom comes from, the amp?

This would make sense. I had to disable auto stop/start completely because of a similar issue on my ’17. I upgraded the amps and at low volume it was ok. but, if it’s just me in the truck, volume is usually a little higher and I noticed the amps would scram and sometimes POP loudly. No bueno. Or at least it sounded no bueno. I put a volt meter on there and that was pretty easy, I was seeing 8.8 to 9.2 volts while start up was going on.
 

HighwaySentinel

︻デ┳═ー - - - - - - -
Joined
Dec 13, 2020
Posts
1,522
Reaction score
3,322
Location
California
is that where the boom comes from, the amp?

This would make sense. I had to disable auto stop/start completely because of a similar issue on my ’17. I upgraded the amps and at low volume it was ok. but, if it’s just me in the truck, volume is usually a little higher and I noticed the amps would scram and sometimes POP loudly. No bueno. Or at least it sounded no bueno. I put a volt meter on there and that was pretty easy, I was seeing 8.8 to 9.2 volts while start up was going on.
While I have not experienced it myself, I once again used our hidden search feature to bring up something that I had remembered reading in the past. In one of the threads, the three items for fix included update, fuse, and battery. Who knows for sure though.
 
Top