Help Support Ford Raptor Forum by donating:


BD Squadron light stopped working after fixing loose wire

Discussion in 'Ford Raptor Lighting Forum [GEN 2]' started by Robert Wright, Feb 23, 2021 at 12:46 AM.

  1. Robert Wright

    Robert Wright Member

    Posts:
    15
    Likes Received:
    11
    Joined:
    May 6, 2019
    Location:
    Santa Teresa, NM
    Upfitter switch works but light not turning on after electrical wiring repair to a Baja squadron light . So I had a loose connector on one side of my BD squadron light up front. After trying to reconnect the wire on the one side both of my Squadron lights will not turn on. The upfitter switch (#2) still lights up in the cabin but no juice is getting to the actual lights. I am using the wiring harness that came with fog light kit.

    Everything was working fine prior to me trying to fix the loose wire on the lights. So I don’t know if it shorted out the the cable but I would appreciate anyone's advice.
     
  2. CobraJay

    CobraJay Tweaker by trade

    Posts:
    118
    Likes Received:
    80
    Joined:
    Jan 22, 2020
    Location:
    NE Ohio
    I would check the fuses for the upfitters first. If they are good the I would ohm out your light harness wires to ground to see if they shorted somewhere down the line. If those 2 are good then check and see if the lights are shorted. If all that passes check the upfitter wire going to the plug for 12v when turned on. See what you find with these checks.

    *edit*
    If you dont understand electricity or basic circuits find someone who does before you try to figure it out yourself.
     
  3. Robert Wright

    Robert Wright Member

    Posts:
    15
    Likes Received:
    11
    Joined:
    May 6, 2019
    Location:
    Santa Teresa, NM
    Will give it a try. Thank you for help.
     
    CobraJay likes this.

Share This Page