Official 2024 R Quality Issues

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

ToadSmasher2K1

FRF Supporting Member
Supporting Member
Joined
Jun 27, 2015
Posts
2,683
Reaction score
7,096
Location
KC
Come one, come all. What quality issues does your 2024 R have?

I’ve had my R for 4 hours and noticed a few things.

- Corrosion on dual valve solenoid
- Hairline crack on the top of my driver headlight
- Tailgate appliqué coming off
- Missing valve cover trim piece
- Misaligned rear bumper, lower on passenger side
- Not quality I guess, but honorable mention for spray-in liner not covering the box link mounts

I feel like I’m missing something, I’ll add if I find it. I’m not usually a nitpicker, and I’m sure Ford will fix these issues, but really?

IMG_6083.jpegIMG_6089.jpegIMG_6090.jpegIMG_6088.jpegIMG_6077.jpeg
 

BoostCreep

FRF Addict
Joined
Jun 25, 2021
Posts
1,724
Reaction score
2,201
Location
SoCal
But, but, Big Tommy Callahan promised all of us QC was #1 and this would all be taken care of?!



That missing valve cover cover is an abomination, how does that even happen?? For the box link bedliner area, that’s the way the factory bedliners have always been, they mask that whole square off.
 

dmb359

Full Access Member
Joined
Mar 18, 2020
Posts
182
Reaction score
111
Location
Minneapolis
Haven’t noticed anything after a day, but maybe I’ll go over it a little closer now
 

BoostCreep

FRF Addict
Joined
Jun 25, 2021
Posts
1,724
Reaction score
2,201
Location
SoCal
Maybe it’s not supposed to have a cover? This picture I found of the RR Crate engine doesn’t have a cover on both sides…

View attachment 451631
Maybe your specific motor is the famous one from that picture to show the coil packs. Mine definitely has the covers on both sides and same with every R I’ve seen.
 

BoostCreep

FRF Addict
Joined
Jun 25, 2021
Posts
1,724
Reaction score
2,201
Location
SoCal
My truck is only a severely underpowered 23R, but this is important. I have been noticing what I thought was pulley/belt squeak on cold start, that goes away after 5 minutes or so after warm up.

Broke out the mechanics stethoscope today to finally take a good look and listen, and the sound really wasn’t from the pulley areas, it sounded like it was coming from the passenger valve cover/oil cap area. So went to go check the oil level and it was an entire quart low! Added a quart of motorcraft 5w50 and no more squeak.

I’m embarrassed as an enthusiast, especially one who owns a gt350 and knows to check oil levels, that I hadn’t checked it at all yet. Hopefully it didn’t cause any premature wear, but the truck only has 580 miles on it and hasn’t run past 4k rpm’s yet.

I’ll continue to monitor oil levels and see if the sound comes back, but hopefully that was it.

NEW R PEEPS: CHECK YOUR OIL LEVELS!!!
 

Frofan

Member
Joined
Aug 10, 2014
Posts
24
Reaction score
17
Took delivery a couple weeks ago and discovered two large dents in the bed of the truck when I took it for a spray in liner.
 
Top