GEN 2 Need help diagnosing misfire codes under certain conditions.

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

dillard09

FRF Supporting Member
Supporting Member
Joined
Nov 23, 2013
Posts
1,243
Reaction score
1,506
Location
College Station, TX and Socal
So I chased a misfire at WOT for a long time. I didn't have warranty left so I chased it myself. Coils, plugs, both HP and LP injectors and no change. Did compression tests and all were good. One day I was like why not pull the valve covers and changed the VVT solenoids for S & Gs and haven't had a misfire since. Not saying it's what's wrong with yours but I think it was what was wrong with mine.
Not fun chasing it down but learned so much about my truck in the process.
 
OP
OP
S

sfemti33

Active Member
Joined
Jun 7, 2022
Posts
56
Reaction score
16
Location
Utah
So I chased a misfire at WOT for a long time. I didn't have warranty left so I chased it myself. Coils, plugs, both HP and LP injectors and no change. Did compression tests and all were good. One day I was like why not pull the valve covers and changed the VVT solenoids for S & Gs and haven't had a misfire since. Not saying it's what's wrong with yours but I think it was what was wrong with mine.
Not fun chasing it down but learned so much about my truck in the process.
I'll make sure to mention this! Thank you. I think they changed one (or one side) with my phasers a bit ago but I know not all of them. Thanks.
 
OP
OP
S

sfemti33

Active Member
Joined
Jun 7, 2022
Posts
56
Reaction score
16
Location
Utah
So, all my boots were looking bad and scored so they changed them all. Took shop foreman out in a drive and did several WOT on freeway and seemed fine. It felt better than shes driven in awhile.

Did one more before we got off and get a shutter (which he thought felt like the road) with no code. I put on my reader that had 1, 5, and multiple misfire codes pending, but no CEL. He was stumped said tech should have cleared codes but maybe didn't? Cleared the codes and drove it himself but rush hour stopped him from banging around and replicating.

He swapped around 5 and 6 coils, and said I could drive and try again (to see if misfire moved around) or just leave it for him tomorrow to test when traffic wasn't bad. I opted to leave again. Bonus, cab smelled a bit like oil after all the spirited driving.

Still no resolution, but was better.
 

Trailmaker

Off-road junky
Supporting Member
Joined
Mar 16, 2017
Posts
808
Reaction score
370
Location
Conroe Texas
Following.

I too have a misfire. It’s on 5&6. New coils and plugs. Runs better when outside temp is below 55F. Almost no issues when it is colder then 40 outside. 151k on the OD
Ended up being a gapping issue on my plugs. I went back with OEM plugs with a 0.026 gap. And now she does not have a misfire. The performance plugs had 45k on them.
OP, I hope all is well and wish you a Merry Christmas!
 

Attachments

  • IMG_3434.jpeg
    IMG_3434.jpeg
    367.6 KB · Views: 5
  • IMG_3433.jpeg
    IMG_3433.jpeg
    396.3 KB · Views: 5
  • IMG_3432.jpeg
    IMG_3432.jpeg
    379.2 KB · Views: 5
Top