Go Back   FORD RAPTOR FORUM - Ford SVT Raptor Forums - Ford Raptor > GEN 1 (2010-2014) Ford SVT Raptor Forums > Ford SVT Raptor General Discussions [GEN 1]
Become a Supporting Member         Become a Supporting Vendor

Register to remove these ads.


Ford SVT Raptor General Discussions [GEN 1]

Truck randomly shut off while driving...


This is a discussion on Truck randomly shut off while driving... within the Ford SVT Raptor General Discussions [GEN 1] forums, part of the GEN 1 (2010-2014) Ford SVT Raptor Forums category!
Anyone had this happen before? Any idea what it could be? When driving into work today, I went to make ...


User Tag List

Like Tree2Likes
  • 1 Post By 1BAD454SS
  • 1 Post By Allmarine

Reply
 
LinkBack Thread Tools Display Modes
Old 05-17-2018, 02:28 PM   #1 (permalink)
Junior Member

 
Join Date: Sep 2016
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default Truck randomly shut off while driving...
Anyone had this happen before? Any idea what it could be?

When driving into work today, I went to make a right hand turn into the parking lot and my truck just COMPLETELY shut off. I'm talking, steering wheel locked (no, not even like just the power steering was lost - LOCKED), all electronics in truck went off, and it came to a complete halt. The small screen in the cluster popped up with a bunch of things, and I only caught a "low oil" light.

Scared the piss out of me. Tried to restart it immediately and nothing worked. Second time I tried it fired right up.

I checked the oil level and its perfect.
Checked for codes - none.
Checked for any obvious electrical signs like fuses, battery cables rubbing / frayed, etc. and nothing. Everything looks perfect.

Anyone have any ideas? I'm baffled, especially with no codes. The only thing I could think is maybe the lock cylinder is fucked up since the steering wheel locked? Is this a common thing?




Verruckt is offline   Reply With Quote
Old 05-17-2018, 02:43 PM   #2 (permalink)
 
EricM's Avatar
Full Access Member

 
Join Date: May 2016
Location: Cincinnati, OH
Posts: 947
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)

Default
Sorry no help here.

I will tell you the story of my 2003 Cobra stalling on me one time though. Went to take off from a light and it just died as soon as I started moving. It took 3 times of cranking over to get it to fire and I had to give it gas to stay running. Limped it into a nearby lot and looked it over, everything looked fine. It started back up just fine and has run perfect ever since- that was 10 years ago.


__________________
2013 Tux Black SuperCrew.

Nobody gives a crap where your post was sent from...
EricM is offline   Reply With Quote
Old 05-17-2018, 05:53 PM   #3 (permalink)
 
AndysLog's Avatar
FRF Addict

 
Join Date: Jan 2017
Location: Moro IL
Age: 28
Posts: 1,102
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)

Default
sounds like a battery or that fuse 27 crap.
what year and miles.
AndysLog is offline   Reply With Quote
Old 05-17-2018, 06:07 PM   #4 (permalink)
Junior Member

 
Join Date: Sep 2016
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
Originally Posted by AndysLog View Post
sounds like a battery or that fuse 27 crap.
what year and miles.
Battery defnitely isn't it. It's a year old Odyssey and voltage is good / charging system is good. It's a 2013 Roush with about 70,000 miles.

I did some searching and it looks like it could be the fuse 27 thing. I have the kit at home to do it (hasn't been done yet). About to bust out the electrical diagrams and see what's tied to that fuse besides the fuel pump as I can't just see the fuel pump cutting out killing EVERYTHING in the truck, unless its shorting out to ground.
Verruckt is offline   Reply With Quote
Old 05-17-2018, 08:38 PM   #5 (permalink)
 
AndysLog's Avatar
FRF Addict

 
Join Date: Jan 2017
Location: Moro IL
Age: 28
Posts: 1,102
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)

Default
yea if your fuel pump cuts out your truck stops running 100% lol.
AndysLog is offline   Reply With Quote
Old 05-18-2018, 09:59 AM   #6 (permalink)
 
1BAD454SS's Avatar
Full Access Member

 
Join Date: Aug 2017
Age: 41
Posts: 143
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)

Default
Fuse 27 i'm betting. All the warning lights come on because ECU thinks truck is running but its not, that why u get low oil press light.
Allmarine likes this.


__________________
2014 FX4 Tremor 420rwhp ,2010 Raptor 6.2L 2.9 Whipple 650 hp kit .2002 Lightning 3.4 whipple 800 RWHP, 1993 454 SS 502 ci and 2.4 kennebell, 1979 10th annivesary trans am 400 4spd ,2015 POLARIS Scrambler 1000,
1995 BANSHEE ,1985 Yamaha RZ500 4 cylinder 2stroke
1BAD454SS is offline   Reply With Quote
Old 05-18-2018, 10:25 AM   #7 (permalink)
Junior Member

 
Join Date: Mar 2017
Location: Perth, Western Australia
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default
Its the fuse 27 arcing out, best to get the relocation kit and shift it asap before it melts your fuse panel.
Hasty likes this.
Allmarine is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Truck keeps turning off while im driving Bigblue01 Ford Raptor Problems and Questions Forum 7 08-08-2018 02:49 PM
Did my l truck die or shut off? JetDriver480 Ford F-150 Raptor General Discussions [GEN 2] 18 07-01-2017 02:23 AM
How do you feel driving a race car compare to your truck?!!! Fellow Ford SVT Raptor General Discussions [GEN 1] 26 06-28-2014 09:20 AM
New truck, still driving my Raptor! mouldman1 Ford SVT Raptor General Discussions [GEN 1] 16 09-20-2013 10:06 PM
Who is driving my Truck? Soldier64 2013 Ford SVT Raptor Forum (Reply Only) 60 07-09-2013 03:07 PM



GM Truck Forum
Chevy Tahoe Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Tahoe Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Land Rover Forum
Scion FR-S Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum