GEN 2 Whipple Stage 1 Kit Feedback Thread!

Discussion in 'Ford Raptor Engine Discussion and Performance Mods' started by Toadster, Jan 4, 2018.

Feedback on Whipple Tune

  1. Love It

    19.8%
  2. Still Testing

    4.0%
  3. Unsure

    6.3%
  4. I'm just here to watch...

    72.2%
Multiple votes are allowed.
  1. jikjak

    jikjak Full Access Member

    Posts:
    115
    Likes Received:
    29
    Joined:
    Feb 12, 2017
    I also updated to Sync 3 V3.0 via USB with no problems (after whipple tune). The wifi method wasnt working for me though.

    ---------- Post added at 09:35 PM ---------- Previous post was at 09:33 PM ----------

    Im currently running the whipple tune and intake with Full Race IC and Stainless Works downpipes, no problems and it runs great. I also have a Borla Type s that I will be installing next week.
     
  2. TXRaptor

    TXRaptor Full Access Member

    Posts:
    759
    Likes Received:
    195
    Joined:
    Sep 15, 2010
    Let us know how loud it is with the SW DPs and Borla S Type cat back.
     
    jikjak likes this.
  3. mad man

    mad man Full Access Member

    Posts:
    95
    Likes Received:
    73
    Joined:
    Jun 5, 2014
    Stock tune

    What was the results?
     
    Last edited: Jun 4, 2018
  4. jikjak

    jikjak Full Access Member

    Posts:
    115
    Likes Received:
    29
    Joined:
    Feb 12, 2017
    It isreally loud with SW dps and borla s-type exhaust, even louder than atak on its own. My wife drove off aggressively while I was outside and it makes you want to wear ear protection. There was a bit of sharpness to it like shooting .17hmr without earpros. The truck did sound great with stock exhaust and SW dps . I also believe that Borla s-type on its own would be fine as well (based on sound clips and also hearing the ATAK exhaust in person.

    I am leaving town in a few days so i probably wont be able to drive enough to break in the exhaust. Ill do so when im back in mid july and see if it gets any better. if the sound tightens up then it might be okay but i fear that ill have to take one of the parts out of the equation.
     
    Last edited: Jun 8, 2018
  5. 10SpdsOfFury

    10SpdsOfFury FRF Supporting Member Supporting Member

    Posts:
    328
    Likes Received:
    287
    Joined:
    Jul 16, 2017
    Location:
    Jacksonville FL
    Update


    The Whipple plaque on the CAI disappeared and the 4 holes go all the way through to the inside of the tube, i swapped back for the stock intake so I can seal the Whipple up. I went for a test drive and man the truck is so quiet. lol

    So everyone keep a eye if yours is getting lose or missing a screw.
     

    Attached Files:

  6. Booth9999

    Booth9999 Full Access Member

    Age:
    39
    Posts:
    542
    Likes Received:
    125
    Joined:
    Nov 19, 2017
    Location:
    Idyllwild
    I wonder where the rivets went?
     
  7. TXRaptor

    TXRaptor Full Access Member

    Posts:
    759
    Likes Received:
    195
    Joined:
    Sep 15, 2010
    Yikes! I hope they fell forward along with the plaque..
     
  8. 10SpdsOfFury

    10SpdsOfFury FRF Supporting Member Supporting Member

    Posts:
    328
    Likes Received:
    287
    Joined:
    Jul 16, 2017
    Location:
    Jacksonville FL
    Called Whipple yesterday and explained to them about the plaque being MIA and asked about getting another one and they said no problem and shipped me out another one today. I appreciate the quick response and getting it resolved.
     
    raptor36 likes this.
  9. ericburney

    ericburney Member

    Posts:
    6
    Likes Received:
    7
    Joined:
    May 23, 2017
    Location:
    southern California
    I had some misfires as well...turned out I forgot to gap the plugs from factory (0.28"-0.30") to Whipple spec 0.25" as shown on page 7 of 7 item 15. That fixed it.
     
  10. ArcticRaptor

    ArcticRaptor Member

    Posts:
    43
    Likes Received:
    22
    Joined:
    Mar 9, 2018
    Location:
    Fairbanks, Alaska
    Posting an update on the main Whipple thread. I was provided with a new tune this week that included a newer TCM update from Ford as well as an updated PCM tune from Whipple. The 3-4 and 4-5 odd shifts are now gone. The truck feels like it pulls much faster at higher RPM's now. Before I had a very fast 0-30, but then it didn't seem to maintain the pull up to 60-70mph. Very happy with the new tune and the customer service from Whipple was top notch. I e-mailed them on Wednesday and had the tune installed Friday morning.
     
    MTF, Sharkus29 and 10SpdsOfFury like this.

Share This Page