What seems to be the problem Raptor??

Discussion in 'Ford Raptor Maintenance Forum' started by LEGORAPTOR, Jul 25, 2011.

  1. LEGORAPTOR

    LEGORAPTOR Full Access Member

    Age:
    31
    Posts:
    479
    Likes Received:
    11
    Joined:
    May 19, 2011
    Location:
    Deep South Texas
    So I took my raptor out to the beach this past weekend to try the new M/T tires and had a badass time trying this baby out in the sand dunes. After though when I was on my way back home, Everytime I got to about 80mph I felt the truck shake/vibrate a lot. The I also let the stering wheel go and it would slowly but surely start leaning to the right side. Is it the alignment? Do I have to get tires balanced again? Was is during the crazyness of my off roading that this occured?

    P.S- I'll post pics and vidz later this week of my adventure =P

    THX
     
  2. pirate air

    pirate air will plunder your booty Supporting Member

    Posts:
    4,253
    Likes Received:
    1,328
    Joined:
    Jul 11, 2010
    Location:
    Texas
    If it shakes its a tire balance problem. I would first check that you don't have mud/sand packed up inside the wheel. If you do, than that could very possibly be your shake. If not, it sounds like the tires need re balanced. The pull could be an alignment issue, low tire psi, or bad tire.
     
  3. LEGORAPTOR

    LEGORAPTOR Full Access Member

    Age:
    31
    Posts:
    479
    Likes Received:
    11
    Joined:
    May 19, 2011
    Location:
    Deep South Texas
    Thanks

    I'll check tire balance and alignment this week as well as do another pressure wash on wheels and undercarriage just to make sure theres no sand/mud stuck under there. Thanks a lot.
     
  4. Rat

    Rat Well-Known Member

    Posts:
    283
    Likes Received:
    0
    Joined:
    May 23, 2011
    Location:
    under the 3rd st bridge
    If you were having "fun" you may have bent something ? How is the bed alignment ?
     
  5. Badrap

    Badrap FRF Addict

    Age:
    63
    Posts:
    1,357
    Likes Received:
    344
    Joined:
    Jun 20, 2011
    Location:
    Haslet, Texas
    Everyone says these things won't do a 100+, BS mine will push 120 but it feels like she is wanting sand and not pavement. It has done this since day one. In the desert she feels fine with no sideways shake or control problems.
     
  6. DEADEYE

    DEADEYE Full Access Member

    Posts:
    491
    Likes Received:
    26
    Joined:
    Apr 16, 2011
    Location:
    MN
    DId you put new rims on with the M/T's ? Check the weights , tape weights ? It ahould be almost impossable with out noticeing when you did it ,but you could have knocked a weight off . I would take it back to where you bought the wheels or had them mounted.
     
  7. whtrapta

    whtrapta Ostrich Wrangler

    Age:
    27
    Posts:
    5,489
    Likes Received:
    911
    Joined:
    Jan 17, 2011
    Location:
    Bolivar/Springfield, MO
    Sounds like tire weights. 100+? I put mine on the dyno and as soon as I hit 100 power was cut. The fastest I hit was 102
     

Share This Page