Help Support Ford Raptor Forum by donating:


TurboSmart EM BOV

Discussion in 'Ford F-150 Raptor General Discussions [GEN 2]' started by SlickMachine, Feb 8, 2020.

  1. Oahutodd

    Oahutodd Member

    Posts:
    8
    Likes Received:
    8
    Joined:
    Feb 9, 2021
    Location:
    Colorado
    That’s just too easy and fully functional. I was able to get the connector seated. But bov 100% silent. TS are sending new actuator with correct plug/harness. If not obviously audible I’ll avoid any possible overboost and return it for a refund. It should just be so simple. The unit looks great quality but it’s gotta work well for the $329. I tested connector & factory harness and it’s got perfect continuity. So not a signal/connector issue. Either valve or electronic actuator. One more try
     
    Last edited: Mar 4, 2021
  2. Oahutodd

    Oahutodd Member

    Posts:
    8
    Likes Received:
    8
    Joined:
    Feb 9, 2021
    Location:
    Colorado
    Got it working.

    But before doing install over I wanted to just wash my hands of the issue and get refund. Wasted enough of my time. I asked TS vendor to issue pre paid RMA shipping label since they sent part from Turbo Smart with incorrect plug. Response; “if it can be resold and was never attempted to install would issue RMA tag”. Apparently this employee doesn’t understand English. I paid for the part and wanted the part. I didn’t “change my mind”. I spend better part of a day installing it - to find plug doesn’t fit (which was verified by Richard at Turbo Smart!). I guess if they “could trick the next customer it was new & uninstalled” they would take it back for a refund - rather then take the issue up with Turbo Smart - the business who sent it out with wrong plug. Decided to make shipping incorrect part back for refund my expense. Needless to say enjoy the $3K order. Cause likely won’t be patronizing your business again. The employee either is a shyster running rouge or trained to do & say exactly what he did. This wasn’t my issue. I paid my $. I was sent parts that wouldn’t work. Rather than step up and refund my money - made it my issue. Not playing that game again when looking to drop several more thousand dollars. I’ll deal with Cobb direct or new vendor. Sucks. Shit canned future business over $15 RMA ship label.

    The fact they confirmed Baja Designs S8 LED would fit with Cobb front mount behind grill intercooler which I’m guessing isn’t the case now pretty well seals the deal. The knee jerk to take that $$$ won’t serve long term. I’d of gladly bought a different $1,000.00 LED bar that was compatible. Rona gots folks doing scandalous BS burning bridges when no need. The money & future sales were there for the taking. But petty legit bs refund antics & incorrect sales info leave me holding incompatible parts or ship back at my expense. Nope Won’t be fooled again.
     
    Last edited: Mar 4, 2021
    sixshooter_45 likes this.
  3. Pure745

    Pure745 Full Access Member

    Posts:
    137
    Likes Received:
    111
    Joined:
    Dec 13, 2019
    Location:
    Orange County
    I believe mine to be leaking boost as well. I got the orange wrench light, pulled over checked the codes and the error was an overboost indication. I then switched back to Map 0 on my Cobb and now it barely blows off.
     

Share This Page