Help Support Ford Raptor Forum by donating:


Truck dies...then comes back from the dead

Discussion in 'Ford F-150 Raptor General Discussions [GEN 2]' started by Foxcroft007, Aug 25, 2020.

  1. Foxcroft007

    Foxcroft007 Member

    Age:
    58
    Posts:
    15
    Likes Received:
    18
    Joined:
    Jul 17, 2018
    Location:
    Eastern Tennessee
    This is a little strange. I have searched this forum as well as the F-150 community. I can find others with similar issues but I have not found a solution.

    So...my truck will randomly die. It won’t do anything. All electrical everything is completely gone. I’ve tested the battery and it is fine. Dash is black, locks don’t work...nothing. What is a little strange is that when it has happened recently I open the hood and the lights come on and things are back to normal?

    Anyone with similar issue or know what could be causing this? It’s not like a fuse blows because it resets itself and then everything is fine. Opening the hood is odd making me thing that it is some sort of anti theft device but it could be a coincidence.

    the truck is a 2018 with 38,000 miles. I do have extended warranty but I’m not throwing a code and it happens randomly so I’m pretty sure dealer won’t be able to replicate the problem.

    Help.
     
  2. PlainJane

    PlainJane Full Access Member

    Posts:
    511
    Likes Received:
    217
    Joined:
    Apr 3, 2019
    Location:
    San Diego, California
    Never had this this problem, but sounds like a bad ground. Clean all the ground connections.
     
  3. CoronaRaptor

    CoronaRaptor FRF Addict

    Posts:
    16,287
    Likes Received:
    4,823
    Joined:
    Dec 17, 2012
    Location:
    CANADA
    Do you have mice/rats in your area? Check the harnesses over and the connections, maybe one of the plug-ins isn't "latched" in place tight. That's what I would be looking for. Any history at the dealer for anything odd since new? Something replaced recently? Start there, if so. Good luck.
     
  4. hyrepower

    hyrepower Full Access Member

    Age:
    41
    Posts:
    73
    Likes Received:
    13
    Joined:
    Jun 4, 2014
    My brand new 2020 has sputtered pulling up my driveway, I wonder if it is a fuel pump issue??
     
  5. Foxcroft007

    Foxcroft007 Member

    Age:
    58
    Posts:
    15
    Likes Received:
    18
    Joined:
    Jul 17, 2018
    Location:
    Eastern Tennessee
    Reviving this thread

    issue keeps coming back. I think I’ve isolated the issue. Unlock truck and press start button. All power goes out...everything. The only way to get it to come back is to open hood and then close it.

    is there some sort of theft switch under the hood?
     
  6. Gdog

    Gdog Full Access Member

    Posts:
    458
    Likes Received:
    326
    Joined:
    Nov 6, 2018
    Location:
    Colorado
    video tape it the next time it happens and take the truck and the video to the dealer..
     
    peavey02 and smurfslayer like this.
  7. 1BAD454SSv2

    1BAD454SSv2 Full Access Member

    Posts:
    471
    Likes Received:
    413
    Joined:
    Jan 8, 2019
    Location:
    HELL I ZONA
    Check battery cable someone had similar issue while back and cable was not bolted to battery just laying on bolt loose
     
    CoronaRaptor likes this.
  8. jabroni619

    jabroni619 FRF Addict

    Posts:
    1,864
    Likes Received:
    1,189
    Joined:
    Jun 13, 2017
    Probably a stuck purge valve which is a pretty common failure across many Ford vehicles.
     
  9. FordTechOne

    FordTechOne FRF Addict

    Posts:
    1,852
    Likes Received:
    2,322
    Joined:
    Jul 29, 2019
    Location:
    Detroit
    Yes, there is a hood switch that prevents the truck from being remote started if the hood is open. Not sure if I will cause it not to start from the ignition button though. Do you have any aftermarket alarm/anti-theft or other aftermarket components installed?
     
  10. Billybob454ss

    Billybob454ss Member

    Posts:
    27
    Likes Received:
    5
    Joined:
    Nov 23, 2017
    Location:
    Long Island
    I have a 2018 with 31,000 miles ..i had my truck at Ford for the cam
    phaser job last week yesterday i stopped to get gas and when i started my truck
    my whole dash was dead no radio nothing everything was black
    i drove a few minutes stopped and turned the truck off then on ...the dash flickered
    and came back on... now i have the check engine light on..
    dropping the truck at dealer today
     
    Smunczen likes this.

Share This Page