Help Support Ford Raptor Forum by donating:


Sync 3.4 update ford logo

Discussion in 'Ford F-150 Raptor General Discussions [GEN 2]' started by Dirtypope, Oct 28, 2020.

  1. Sunchild714

    Sunchild714 Full Access Member

    Posts:
    126
    Likes Received:
    85
    Joined:
    Apr 14, 2019
    Location:
    Las Vegas
    Is it really an issue?
     
  2. Dirtypope

    Dirtypope Full Access Member

    Age:
    36
    Posts:
    378
    Likes Received:
    228
    Joined:
    Jul 19, 2017
    Location:
    Chicago
    For the first couple hours of driving the system is still doing their own update and response time is sluggish. After the full update everything is working the way it should.

    The new update looks amazing!! It’s like having a new truck!! My favorite thing is the heat steering wheel button is much bigger

    FBFC1296-4468-4E7F-865B-957B8E8EEBEA.jpeg
     
  3. Dirtypope

    Dirtypope Full Access Member

    Age:
    36
    Posts:
    378
    Likes Received:
    228
    Joined:
    Jul 19, 2017
    Location:
    Chicago
    I prefer “raptor” logo over “ford”

    “raptor” logo is back thank god
     
    sixshooter_45 likes this.
  4. waveslayer

    waveslayer Full Access Member

    Age:
    39
    Posts:
    594
    Likes Received:
    380
    Joined:
    Aug 30, 2018
    Location:
    CA
    What year is your truck?

    My wife thinks I only have 3 guns
     
  5. Dirtypope

    Dirtypope Full Access Member

    Age:
    36
    Posts:
    378
    Likes Received:
    228
    Joined:
    Jul 19, 2017
    Location:
    Chicago
    2019. Did the update through WiFi
     
  6. waveslayer

    waveslayer Full Access Member

    Age:
    39
    Posts:
    594
    Likes Received:
    380
    Joined:
    Aug 30, 2018
    Location:
    CA
    Ok. Looking to do my 2018 soon

    My wife thinks I only have 3 guns
     
    Dirtypope likes this.
  7. V6Raptor

    V6Raptor Full Access Member

    Posts:
    75
    Likes Received:
    45
    Joined:
    Jan 8, 2020
    Location:
    ‘Murica
    Did the update few months ago. Some things that I have noticed that others have mentioned, the initially start up after the update will display the “Ford” logo but the “Raptor” start up screen will come back at the next start and it does act slow and sluggish at first but this also goes away after a few starts.
     
    sixshooter_45 and Dirtypope like this.

Share This Page