Help Support Ford Raptor Forum by donating:


Slow start up

Discussion in 'Ford Raptor Problems and Questions Forum' started by jef, Jun 29, 2016.

  1. MTF

    MTF FRF Addict

    Posts:
    3,873
    Likes Received:
    1,033
    Joined:
    Nov 27, 2010
    Location:
    NYC
    I don't believe the PS is the issue.

    Can you monitor the oil injection system for the LPG.
    It might be leaking oil into the intake over night that would certainly cause hard starting.

    I'll ask my friend in Germany if his Dodge Ram pickup truck does that.
    It might be a little different though, he's running a LNG kit.
     
    Last edited: Jul 4, 2016
  2. jef

    jef Full Access Member

    Age:
    37
    Posts:
    238
    Likes Received:
    280
    Joined:
    Mar 30, 2014
    Location:
    belgium
    The lpg has a system to lubricate the valves. The system uses a small pump to get the oil in the engine. The reservoir is mounted lower as the engine, so i don't think it could leak into the engine over night.
    It feels like a mechanical problem. The starter can't get enough speed to get the engine running the first couple seconds.
    I'm gonna take off the belt and see if everything can turned by hand.
    Can i start with the belt off?
     
  3. MTF

    MTF FRF Addict

    Posts:
    3,873
    Likes Received:
    1,033
    Joined:
    Nov 27, 2010
    Location:
    NYC
    Yes, but you don't need to remove the belt, just push the tensioner all the way down, the belt will be free enough to turn your accessories.
     
  4. jef

    jef Full Access Member

    Age:
    37
    Posts:
    238
    Likes Received:
    280
    Joined:
    Mar 30, 2014
    Location:
    belgium
    I just tried this. Everythings moves freely. I could only move the power steering pump clockwise(the way it turns when engine is running) without effort. Almost impossible to turn it counter clockwise. Truck started normal (it was only parked for 3 hours). After i shut down the engine, i could move the power steering pump freely in both directions. I'm going to try this again tomorrow morning before i start the truck again.
     
  5. EddieEK2

    EddieEK2 Member

    Posts:
    1
    Likes Received:
    0
    Joined:
    May 20, 2019
    Location:
    salinas ca
    Hey Jef, Im currently having the same issue that you posted (cold start delay). Its a 2013 with a Roush super charger and JDM tune. It was working fine until a month ago (had it for 1 year already). wondering if you found out the issue. I havent checked the battery ( with a tester), power steering is leaking (that would possibly pull resistance in the drive belt when cold).
     
    Last edited: May 20, 2019

Share This Page