Remote start not working

Gryphon313

Active Member
Joined
Oct 6, 2022
Posts
64
Reaction score
112
Location
Western, WA
I had this issue when I bought my truck last month. The dealer provided two new aftermarket keys, but the remote start function was not working. I fixed it over the weekend using ForScan and two new non-programmed keys.

What was the process you used to program your keys?
 
OP
OP
Tahoetim_42

Tahoetim_42

Member
Joined
Jul 25, 2022
Posts
32
Reaction score
14
Location
Corona, CA
I had this issue when I bought my truck last month. The dealer provided two new aftermarket keys, but the remote start function was not working. I fixed it over the weekend using ForScan and two new non-programmed keys.

What was the process you used to program your keys?
I hired a keysmith too cut and program the chip and fob. Went just fine when he did it. A week later had my friend turn it on, on the bcm using forscan.
 

Gryphon313

Active Member
Joined
Oct 6, 2022
Posts
64
Reaction score
112
Location
Western, WA
Ok. You may want to try this:

1. Get two new unprogrammed keys cut.
2. Use a currently programmed key and hook up ForScan. Double check that remote start is enabled.
3. Go into PATS Key programming in Forscan and select Program Ignition Key
4. When prompted, insert newly cut unprogrammed key and wait for the 12 minute times security. Follow prompts if successful.
5. Repeat step 4 for second uncut key.
6. To program the buttons on the keys you will need to have one in the ignition. Open the driver’s door and press the unlock button.
7. Cycle the key on and off 8 times stopping in the on position on the 8th cycle. (Must be done withinin 10 seconds)
8. Immediately press any button on the key in the ignition and then press any button on the other new key. (The doors should lock and unlock if successful)
9. Turn key off and remove.
10. Use your new remote to lock the truck and then double press the remote start button. (Note: for whatever reason, my truck will only remote start if I press the lock button and then double click the remote start button twice.

Hope that works for you.
 
Top