Help Support Ford Raptor Forum by donating:


Rear defrost not working

Discussion in 'Ford Raptor Maintenance Forum' started by stevenstommyboy1, Nov 1, 2019.

Car Parts
  1. StLDave

    StLDave Member

    Age:
    65
    Posts:
    1
    Likes Received:
    0
    Joined:
    Aug 3, 2018
    Location:
    St Louis
    I picked up my 2014 a year or so ago and the defrost worked fine. This winter, it quit. I looked at fuses, breakers, then read about it in here. Figured it was shot. I missed the mirrors as much as anything.

    So sitting at a stop light the other day and jogged the slider back and forth with the defrost button pushed. Lo and behold, the light would blink on every now and then as I jogged the slider near the closed position. With some careful back and forth, I found a position that the defrost stayed on! It has kept working the last few days, so I have hope!

    My plan is to figure out a shim to install to mimic my jogged spot. Will wait for spring, but will let you know if that holds up.

    Anybody else tried this solution?
     
  2. Dane

    Dane FRF Addict

    Age:
    41
    Posts:
    1,939
    Likes Received:
    565
    Joined:
    Sep 20, 2011
    Location:
    Littleton, CO
    It's a contact switch, so that makes sense if it's simply a contact issue. There are a myriad of other issues that can happen though. In my situation your technique yielded no joy. Hopefully it works for you and saves you a butload of cash replacing the whole thing!
     

Share This Page