New 2013 roush raptor stalls

Discussion in 'Ford Raptor Problems and Questions Forum' started by Yorker2005, Jun 11, 2013.

  1. bbnc1

    bbnc1 Member

    Posts:
    1
    Likes Received:
    1
    Joined:
    Jul 29, 2017
    Stalled Raptor while driving

    I have a 2013 Raptor mostly stocked. Just yesterday, I had the same problem as others.....while driving, display says no oil pressure, power steering going out, no throttle control. I was lucky enough that there was a shoulder to pull over on a single lane highway. After I tried to restart, it turned over but not firing up. Luckily, I had a old spare fuel module that I replaced a year ago but didn't throw away. Unplugged the connector to the current fuel module and plugged into my old spare fuel module and the truck fired right up. Drove 50 miles and issue came back but that's because the old module had the same problem before, but I kept it "just in case", and it paid off because plugging back to the first module, truck wouldn't start. Anyway, below is a link to a fuel pump control module that was on a recall. Mine is AA8A-9D412-EA but they say that this module doesn't need a recall. The AA8A-9D412-CA does. However, I think my "EA" version has the exact same symptom as described in the recall. I suspect most truck having same symptoms should check this out first before spending too much money on taking it into dealership. The replacement takes 10min max, and super easy to install (2 bolts). module is located above the spare tires and rear axle, slightly off center to the driver side. I bought an equivalent part in ebay AA8Z-9D370-D which is an OEM replacement part for $24 shipped. This was the part I used a year ago when I replaced the original AA8A-9D412-EA, and it worked fine (for a year). I am buying two and keep one as spare in the truck. The link below also has pictures of the module for those who don't know what it looks like. Hint: Take the two bolts out first before you attempt to unplug the cable since it's a "b..ch" to do it the first time. The tab sits flush with the socket, so you have to push in the plug to loosen the tab, then press the tab hard and wiggle as you pull the cable out. The tab is on top of the connector and not obvious since it is flushed with the tab housing. Hope this helps someone out.


    https://www.google.com/url?sa=t&rct...coln/6&usg=AFQjCNGpZZd9i2muwQA-6gCinhPcuYJ5fw
     
    Last edited: Jul 29, 2017
    MTF likes this.

Share This Page