Help SupportFord Raptor Forum by donating:


Help support Ford Raptor Forum :

Mud guards do they help?

Discussion in 'Ford Raptor Exterior Forum [GEN 2]' started by #1LeadFoot, Feb 12, 2019.

  1. #1LeadFoot

    #1LeadFoot Full Access Member

    Age:
    35
    Posts:
    55
    Likes Received:
    39
    Joined:
    Jan 26, 2018
    Here’s a little before & after. Not just a installation piece but a actual test on weather these mud guards actually do these trucks any good. I went with the Husky mud guards.

     
  2. Johnkn

    Johnkn Full Access Member

    Posts:
    456
    Likes Received:
    266
    Joined:
    Nov 29, 2018
    Location:
    LaPlata, MD
    Geez, sure not a surprising result. I too installed huskys and they look OEM. Only thing I find surprising is that I didn't install the rear set, they are in unopened boxes, I listed them here for sale cheap and no one wants them LOL.
     
  3. x96535

    x96535 Member

    Posts:
    37
    Likes Received:
    30
    Joined:
    Apr 19, 2018
    Thanks for making the video. I’ll be picking up set now too.
     
    #1LeadFoot likes this.
  4. #1LeadFoot

    #1LeadFoot Full Access Member

    Age:
    35
    Posts:
    55
    Likes Received:
    39
    Joined:
    Jan 26, 2018
    I think it’s because the ones in the front look like they are OEM & in the rear it doesn’t look right haha.
     
  5. f150jack

    f150jack Full Access Member

    Posts:
    239
    Likes Received:
    100
    Joined:
    Jul 18, 2018
    Location:
    dallas tx
    just put these on last night, went to park truck this morning and they rub before full lock. U have same problem?I'm running venom rex 602s maybe that half inch offset is problem.
     
  6. Johnkn

    Johnkn Full Access Member

    Posts:
    456
    Likes Received:
    266
    Joined:
    Nov 29, 2018
    Location:
    LaPlata, MD
    For reference, Mine do not rub with the stock 2019 forged wheels
     
  7. #1LeadFoot

    #1LeadFoot Full Access Member

    Age:
    35
    Posts:
    55
    Likes Received:
    39
    Joined:
    Jan 26, 2018
    Yeah mine started rubbing also on full lock turns. Did a slights trim towards the far inside corner of the mud guards to fix the problem.
     
  8. f150jack

    f150jack Full Access Member

    Posts:
    239
    Likes Received:
    100
    Joined:
    Jul 18, 2018
    Location:
    dallas tx
    cool I will bust out the dremel tomorrow. thanks
     
  9. Kowboy17

    Kowboy17 Full Access Member

    Posts:
    207
    Likes Received:
    106
    Joined:
    Jun 16, 2012
    Location:
    in an FBI van
    #1Leadfoot......change your flags on the truck. You have them backwards.
     
    charliebrown, Finnster and PBR ME like this.
  10. PBR ME

    PBR ME Full Access Member

    Posts:
    282
    Likes Received:
    249
    Joined:
    Jan 29, 2015
    Yes, flags should always go the direction they would naturally “wave”. So unless you spend the majority of your time in reverse....


    Sent from my iPhone using Tapatalk
     

Share This Page