Make sure you do the Fuse 27 fix!!!

Discussion in 'Ford SVT Raptor General Discussions [GEN 1]' started by radelow, Nov 12, 2018.

  1. Klavius Morph

    Klavius Morph Member

    Posts:
    4
    Likes Received:
    0
    Joined:
    Nov 4, 2018
    Location:
    Central Washington
    This really got me thinking -- my 2011 SCREW stranded me several months ago and I thought it was a dirty MAF sensor, so I pulled it and cleaned it and it's been running fine since. Now I'm wondering if it was a fuse 27 issue.

    I pulled the fuse and neither it nor the terminal showed any signs of heat damage, but I'm going to do the fix anyway.
     
  2. daddycreswell

    daddycreswell Full Access Member

    Posts:
    997
    Likes Received:
    307
    Joined:
    Jan 30, 2012
    Location:
    Lebanon Tennessee
    About six months ago I ran into this problem, I swapped the fuse out....and it had been fine until yesterday. Went out to start it and nothing, just cranking..... I do have the relocate kit....just never installed it. Anyway, I looked at the fuse and it was fine, changed the fuel pump relay in the same fuse box....nothing. Do you think the fuse is still the problem? I called around and it looks like $650.00 is going rate to have the fuel pumped changed out in Lebanon Tn. Should I do the relocate kit and see where that leads me? I guess I should, and maybe save me some cash.
     
  3. Chiefapple

    Chiefapple Full Access Member

    Posts:
    196
    Likes Received:
    121
    Joined:
    Nov 3, 2017
    Location:
    Sparta, WI

    The fuse may be fine. The socket itself may not be.


    Sent from my iPhone using Tapatalk
     
  4. daddycreswell

    daddycreswell Full Access Member

    Posts:
    997
    Likes Received:
    307
    Joined:
    Jan 30, 2012
    Location:
    Lebanon Tennessee
    I think I'll go home and fix it. Be worth the try instead of dropping $650.00 on the fuel pump. I know these things can go a t any time, but the truck is a 13 with 43k miles. So it's hard to believe that's the culprit.
     
  5. Chiefapple

    Chiefapple Full Access Member

    Posts:
    196
    Likes Received:
    121
    Joined:
    Nov 3, 2017
    Location:
    Sparta, WI

    You’re right. It’s hard to believe. Go spend the $650. If that doesn’t work I would guess that they could relocate the fuse for you after.


    Sent from my iPhone using Tapatalk
     
  6. Klavius Morph

    Klavius Morph Member

    Posts:
    4
    Likes Received:
    0
    Joined:
    Nov 4, 2018
    Location:
    Central Washington
    Has anyone in the thread ever had this gremlin pop up while driving & killing the engine, or is it mostly something that shows up when trying to start a cold engine?
     
  7. daddycreswell

    daddycreswell Full Access Member

    Posts:
    997
    Likes Received:
    307
    Joined:
    Jan 30, 2012
    Location:
    Lebanon Tennessee
    Well....I did the relocation this afternoon....no joy. The truck was put on the rollback this afternoon. Wasn't sure it was going to fit......[​IMG]

    Sent from my SM-G950U using Tapatalk
     
  8. Chiefapple

    Chiefapple Full Access Member

    Posts:
    196
    Likes Received:
    121
    Joined:
    Nov 3, 2017
    Location:
    Sparta, WI
    That sucks ass. Still have a warranty hopefully.


    Sent from my iPhone using Tapatalk
     
  9. daddycreswell

    daddycreswell Full Access Member

    Posts:
    997
    Likes Received:
    307
    Joined:
    Jan 30, 2012
    Location:
    Lebanon Tennessee
    Unfortunately no.....oh well.

    Sent from my SM-G950U using Tapatalk
     
  10. SVTFordRaptor

    SVTFordRaptor Full Access Member

    Posts:
    286
    Likes Received:
    111
    Joined:
    Sep 20, 2014
    My fuel pump went out at 30,000 miles. Fuse 27 appeared to be fine, but I replaced it with the relocation kit just to be safe.


    Sent from my iPhone using Tapatalk
     

Share This Page