Help Support Ford Raptor Forum by donating:


High idle problem

Discussion in 'Ford Raptor Engine Discussion and Performance Mods' started by Ratpatator, Apr 2, 2020.

GotExhaust
  1. Ratpatator

    Ratpatator Full Access Member

    Age:
    35
    Posts:
    156
    Likes Received:
    85
    Joined:
    Jul 5, 2016
    Location:
    Mtn. Green, Utah. GJ, Colorado.
    I will definitely give this a try. I did open the TB up before I installed to make sure everything was working right. Thanks
     
  2. Ratpatator

    Ratpatator Full Access Member

    Age:
    35
    Posts:
    156
    Likes Received:
    85
    Joined:
    Jul 5, 2016
    Location:
    Mtn. Green, Utah. GJ, Colorado.
    That makes sense. With all the electrical and computer controlled stuff most vehicles will be almost identical.

    The only issue I had with shifting was the shift point seemed to be off. Just havent taken the time to track them I would just use the manual mode all the time. Although I do like the shift points on this new tune with the new parts.
     
  3. josh80

    josh80 Member

    Posts:
    8
    Likes Received:
    0
    Joined:
    Nov 9, 2018
    Location:
    Colorado
    Take a look at your pcv valve.
     
  4. Ratpatator

    Ratpatator Full Access Member

    Age:
    35
    Posts:
    156
    Likes Received:
    85
    Joined:
    Jul 5, 2016
    Location:
    Mtn. Green, Utah. GJ, Colorado.
    I owe you a beer sir! Pretty sure this could be the problem... KIMG0610.JPG

    The guts had fallen into the valve cover so pulled it of and found these 15878718174841495153913698002377.jpg
    Had to turn the cover upside down and shake it to get them out. Didn't find the little black plastic part but pretty sure it came out.
     
    josh80 likes this.

Share This Page