Help Support Ford Raptor Forum by donating:


Ford Raptor Fuel Pump Fuse Issue

Discussion in 'Ford Raptor Problems and Questions Forum' started by billybob974, Dec 30, 2014.

  1. SVTFordRaptor

    SVTFordRaptor FRF Addict

    Posts:
    1,037
    Likes Received:
    703
    Joined:
    Sep 20, 2014

    I have never heard or read of such a thing happening. However, hopefully for you that is all it was.
     
    KCM likes this.
  2. BenBB

    BenBB Full Access Member

    Age:
    48
    Posts:
    851
    Likes Received:
    524
    Joined:
    Apr 21, 2016
    Location:
    Lots of different places
    Yes. Google FPDM, common problem, seems to be more commonly the connector but have read a few instances of the module failing.

    Sent from my SM-G973U1 using Tapatalk
     
  3. SVTFordRaptor

    SVTFordRaptor FRF Addict

    Posts:
    1,037
    Likes Received:
    703
    Joined:
    Sep 20, 2014

    Those are mostly for 04-08 F150s. I have not seen any for the Gen 1. Maybe I am wrong?
     
  4. KCM

    KCM Full Access Member

    Posts:
    73
    Likes Received:
    24
    Joined:
    Apr 4, 2019
    Location:
    California
    My FPDM is above the spare tire though. There was nothing wrong with that part. Does it connect on top of the gas tank because that’s where the mud was. If so is it possible to replace the connection points?
     
  5. The Car Stereo Company

    The Car Stereo Company aka nosbusa Supporting Vendor

    Age:
    42
    Posts:
    26,282
    Likes Received:
    9,422
    Joined:
    Jul 8, 2012
    Location:
    here, on frf
    its a sealed connection. not sure how exterior mud could cause the problem.
     
  6. KCM

    KCM Full Access Member

    Posts:
    73
    Likes Received:
    24
    Joined:
    Apr 4, 2019
    Location:
    California
    I’m not very familiar with the wiring on top of the gas tank but that’s what the mud was effecting. After cleaning it out and making sure everything was connected my truck started right up.

    Edit: The fuel pump wiring harness is on top of the gas tank so maybe the dirt/mud/water caused the sealed connection to not be sealed anymore?
     
    Last edited: Feb 11, 2020
  7. Wilson

    Wilson FRF Addict

    Age:
    46
    Posts:
    26,124
    Likes Received:
    10,080
    Joined:
    Jan 27, 2012
    Location:
    South Dakota
    or maybe there is a bad wire and when you moved it it reconnected.
     
    KCM likes this.

Share This Page