Help Support Ford Raptor Forum by donating:


GEN 2 First Problem So Far With 2019

Discussion in 'Ford Raptor Problems and Questions Forum' started by Ted Schroeder, Feb 16, 2020.

  1. K223

    K223 FRF Addict

    Posts:
    2,462
    Likes Received:
    980
    Joined:
    Sep 15, 2019
    Location:
    Florida
    You occasionally hear of someone having a problem and then another guy goes into a panic about his healthy truck that may go bad. I couldn’t agree more with @goblues38 post.

    I’m glad the OP got his truck fixed.
     
    Ted Schroeder and goblues38 like this.
  2. Ted Schroeder

    Ted Schroeder Member

    Posts:
    48
    Likes Received:
    75
    Joined:
    Nov 6, 2019
    Location:
    NC
    I have no reason to panic when you have a good dealership they will make it right has been my experience. With all the technology in these trucks I pretty much expect something else to go bad. I was given the option of leaving the truck there until the part comes in this week. They offered another Raptor to use.
     
  3. WraptorBoy

    WraptorBoy 2019 Sep/Oct build

    Posts:
    132
    Likes Received:
    41
    Joined:
    May 20, 2019
    Location:
    US
    I agree with this.

    The problem, specifically for me and I'm guessing a lot of people, is not that something broke or that something may break later. It's dealing with ahole individuals on soap boxes at dealerships that tell you "there's no issue" or the "tech" who does a crap job and creates even more issues.

    I, for one, would not have a worry about failures if I could take my vehicle to a dealer and get perfect service and fixes that were fixed once and permanently. This includes doing the job correctly etc etc. But for a lot of dealerships, this just isn't the case base on my own empirical evidence.

    I would expect this current shady crap from non-dealers. But, we get it from both dealers and non-dealers aloine. This is the real issue.

    So, for me, it's not the failure or future faliures that is the concern. It's the hassle of dealing with jerks, re-fixes and problems that bad techs/idiots create because of their incompetence/carelessness.
     
    Ted Schroeder likes this.
  4. K223

    K223 FRF Addict

    Posts:
    2,462
    Likes Received:
    980
    Joined:
    Sep 15, 2019
    Location:
    Florida
    Nope and your going about it just fine. It’s more of a reference to people who suddenly think the same problems will happen to there truck just because one guy had an issue with his.

    I hope your truck is running good and you can move past it now.
     
    Ted Schroeder likes this.
  5. Ted Schroeder

    Ted Schroeder Member

    Posts:
    48
    Likes Received:
    75
    Joined:
    Nov 6, 2019
    Location:
    NC
    I promised a update on my 2019 Raptor. They replace the control module under the dash driver side. Truck is running normal and no more crazy stuff going on. Such as check 4 wheel drive, blank center screen with gauges not working, center stack not functioning, lane departure not working, wrench icon lite up and fuel mileage at 8 miles per gallon hand calculation done. Few more things I can’t remember but all is cool they ordered the part and installed first thing the next morning.
     
    JohnyPython, 06z and smurfslayer like this.
  6. tplee

    tplee Full Access Member

    Posts:
    252
    Likes Received:
    102
    Joined:
    Sep 28, 2014
    Location:
    South Carolina
    Really appreciate you taking the time to post this!

    Is you fuel mileage back to normal as well?

    Sent from my Pixel 3a using Tapatalk
     
  7. RaptorVette

    RaptorVette Full Access Member

    Posts:
    278
    Likes Received:
    109
    Joined:
    Oct 12, 2012
    Location:
    Corpus Christi, TX
    So I just had this happen today! 2019 with 12,000 miles. I started the truck and no electronics worked but the truck was driving fine. After about a mile, the gauges and radio came on and the windows worked again. Then the yellow wrench light showed up.

    Got home, turned the truck off for a few minutes then started it back up and the wrench was gone. Weird! Hopefully it won't come back.
     

Share This Page