Help Support Ford Raptor Forum by donating:


engine Cut-off and low oil pressure warning!!

Discussion in 'Ford Raptor Problems and Questions Forum' started by Raptor Embroidery, Mar 10, 2012.

  1. VIPLV

    VIPLV Member

    Posts:
    11
    Likes Received:
    5
    Joined:
    Feb 28, 2019
    Location:
    LAS Vegas,NV
    No oil leaks? Check oil, how many miles you drive since last oil change?

    Lots of raptors burning excessive amounts of oil. Saying oil getting into the headers but no leaks.
     
  2. Mitchell007

    Mitchell007 Member

    Posts:
    10
    Likes Received:
    2
    Joined:
    Dec 7, 2015
    Most of these posts have been around a while. I hope that you guys have figured it out, any help is appreciated. My 2014 Raptor with 105,000 miles (I have had the truck since new). It has been doing the samething with more and more frequentcy over the last few tanks of gas. I am getting the low oil pressure and the wrench showing up when the truck stalls. It always starts right back up and runs fine. I had done it while sitting at idle and also when slowing down to a stop. Once it sarted to run rough before stalling but still started right back up.

    One thing I have noticed that’s different with mine is from time to time at highway speeds 70-80 while cruising I get this kick. It feels like it does when the speed limiter kicks in but only for a split second then it’s fine. Ideas?
     
  3. Raptized

    Raptized Full Access Member

    Posts:
    534
    Likes Received:
    111
    Joined:
    Dec 30, 2016
    Location:
    Raptorida
    Did you change out the fuse?

    Sent from my SM-N950U using Tapatalk
     
  4. Flaltlander1414

    Flaltlander1414 Full Access Member

    Posts:
    132
    Likes Received:
    42
    Joined:
    Apr 24, 2013
    Location:
    Roseville, CA
    Wife was out of town with the truck, first problem without me!
    She tries to start it and it just turns over and over. Finally asks a guy in the grocery store parking lot to jump her. She thinks it’s the battery. It starts back up. Takes the truck and had battery checked out a autozone and they say it’s good. She continues to drive to Lake Tahoe CA with 4 kids.
    4days later This afternoon I get a call the truck died while on freeway coming home with LOP light. had her check the oil dip stick over FaceTime what an ordeal. It was half full. Almost got a divorce over trying to find the hood latch release.
    I drove 90 miles with an Arsenal of tools and oil. No codes. I got there added oil. Truck fired up. While driving engine died while going uphill, truck engine stalled with semi truck merging to my right and 3 cars bumper to bumper to my left. Steering went, no acceleration. I braked with no hydraulic braking as hard as I could with 4 kids in the car. I legitimately thought we are all gonna die.
    I race super bikes amateur and have never more afraid tonight Of an engine stall.
    Did ford put a recall on fuse 27 or do I need to reposition it myself?

    I’m gonna check the fuses in the morning. After reading this thread it seems to be the culprit.
    I have 2011 Screw 108k never an issue. Great truck
     
  5. Raptized

    Raptized Full Access Member

    Posts:
    534
    Likes Received:
    111
    Joined:
    Dec 30, 2016
    Location:
    Raptorida
    There is no recall but just a service bulletin. I did mine in about thirty minutes in my driveway with a kit from Amazon.

    https://www.amazon.com/dp/B01C39T92A/?tag=fordraptorforum-20

    You can report the problem with the NHTSB on their website I believe.
     
  6. Canuck714

    Canuck714 Full Access Member

    Posts:
    665
    Likes Received:
    328
    Joined:
    Jun 11, 2012
    Location:
    San Antonio TX
    I will bet its Fuse 27 and the low oil has nothing to do with it.
    Mine cut out one morning after accelerating hard to make the advanced green on a left turn. As soon as I chopped the throttle entering the intersection it quit. No power steering, and im rolling fast... Good Times!!
     
  7. jasoncolorado

    jasoncolorado Member

    Posts:
    5
    Likes Received:
    2
    Joined:
    Nov 23, 2019
    Location:
    Colorado
    Happened to me today on a blind corner hill. This is absolutely a safety issue. Here is the culprit

    83D31691-4616-4ABE-99D3-4898FB46D78A.jpeg
     
    CoronaRaptor likes this.
  8. CoronaRaptor

    CoronaRaptor FRF Addict

    Posts:
    15,367
    Likes Received:
    4,289
    Joined:
    Dec 17, 2012
    Location:
    CANADA
    Damn, worst case scenario!
     
    jasoncolorado likes this.
  9. jasoncolorado

    jasoncolorado Member

    Posts:
    5
    Likes Received:
    2
    Joined:
    Nov 23, 2019
    Location:
    Colorado
    I feel sorry for those guys early on that replaced an engine due to a simple fuse.
     
  10. aswift007

    aswift007 Member

    Posts:
    3
    Likes Received:
    1
    Joined:
    Jan 20, 2020
    Location:
    Elburn, IL
    Mine is a 2019 Raptor, 6800 miles. Had the same thing happen on 2 separate occasions. Floored it to pass. Truck lurched, lost power, then low oil warning. Pulled over, gauge showed nothing for oil pressure. Shut off truck, then I restarted it. Gauge back, reading normal.

    On mine, the fuel pump is fuse #50, not #27. I pulled it, looks normal.

    This is not what I paid for, any other suggestions before taking it back to dealer, again?
     

Share This Page