Help Support Ford Raptor Forum by donating:


Ease my concerns....

Discussion in 'Ford Raptor Engine Discussion and Performance Mods' started by FiveOsvt, Sep 13, 2020 at 8:10 AM.

GotExhaust
  1. FiveOsvt

    FiveOsvt Member

    Posts:
    12
    Likes Received:
    22
    Joined:
    Sep 10, 2020
    Location:
    Maryland
    So a few days ago I purchased a used 2014 gen 1 with 49,500 miles. Obviously being the first 6.2 I have purchased I am unaware of its "normal" engine characteristics. It seems to idle a little rough which I have heard is typical due to cam profile but last night I decided to drive home with the radio off. I noticed under light to moderate acceleration a ticking/exhaust leak like sound that seemed to be coming from the drivers side area that could be heard in the cabin pretty easily. Is this normal for this truck?. Are the injectors just that loud?. Its definitely not a knocking sound more like a hissing/ticking combined sound if that makes sense. Thanks for all help/knowledge.

    Sent from my SM-G960U using Tapatalk
     
  2. Movinon

    Movinon Full Access Member

    Posts:
    97
    Likes Received:
    33
    Joined:
    Sep 15, 2010
    Location:
    OK
    Just turned 128k miles i heard the same at 100k changed plugs all smooth again. Just my experience. Smooth and no engine noise.

    Sent from my SM-N960U using Tapatalk
     
    SS308 likes this.
  3. B E N

    B E N Full Access Member

    Posts:
    490
    Likes Received:
    264
    Joined:
    May 1, 2019
    Location:
    Frederick, CO
    Mine makes a noise, possibly similar to what your describing. I believe it's the throttle body servo.
     
  4. FiveOsvt

    FiveOsvt Member

    Posts:
    12
    Likes Received:
    22
    Joined:
    Sep 10, 2020
    Location:
    Maryland
    May give this a try, never hurts to change the plugs anyway.

    Sent from my SM-G960U using Tapatalk
     
  5. CoronaRaptor

    CoronaRaptor FRF Addict

    Posts:
    14,241
    Likes Received:
    3,791
    Joined:
    Dec 17, 2012
    Location:
    CANADA
    Mine has a slight tick, been like that since new, even hear it with the headers and exhaust.
     
  6. MFNG

    MFNG Full Access Member

    Posts:
    245
    Likes Received:
    190
    Joined:
    Jun 28, 2019
    Location:
    Illinois
    My 2014 6.2L does the ticking thing. Spark plugs are coming up next. Sitting at 102k mi.

    Mine also does the rough idle at low speed. Give her a little gas and she’s fine.
     
  7. Ruckus08

    Ruckus08 Member

    Posts:
    33
    Likes Received:
    19
    Joined:
    Sep 6, 2018
    Location:
    Nashville, Tennessee
    I’ve got 2013 Roush SC. Had the ticking before adding new SW headers and after. I got rid of my idle issues with new sparks, wires and coil boots though. I’d recommend new coil boots if you are replacing sparks anyway. It’s a <15 min job to put new ones on if you’ve already got the air box removed for sparks. Your wires are probably fine but you could replace and not worry for another 100K~. I’ve got 113K on my truck.
     
    SS308 likes this.

Share This Page