Help SupportFord Raptor Forum by donating:


Help support Ford Raptor Forum :

GEN 1 Dash lights go crazy under hard acceleration ...?

Discussion in 'Ford Raptor Problems and Questions Forum' started by Sandfreak520, Jul 4, 2019.

  1. Sandfreak520

    Sandfreak520 Member

    Posts:
    20
    Likes Received:
    0
    Joined:
    Oct 16, 2017
    Location:
    Washington State
    Hey guys I was driving my raptor today and gave it a hard acceleration and the advance Trac light started flashing the check braking system light came on the 4x2 light all came on then the entire dash and stereo blanked out and came back on ..? If I just drive normal it’s fine......? But soon as I mash the throttle the gauge cluster an stereo go crazy like Xmas tree.....? It usually starts with the 4x2 logo shows up then they all start going on and off the warning bing noise starts going off no codes no engine light any help would be great thx
     
  2. The Car Stereo Company

    The Car Stereo Company aka nosbusa Supporting Vendor

    Age:
    40
    Posts:
    24,925
    Likes Received:
    8,338
    Joined:
    Jul 8, 2012
    Location:
    here, on frf
    could be a bad bcm. everything you mentioned is connected to the bcm. might try looking there first.
     
  3. Sandfreak520

    Sandfreak520 Member

    Posts:
    20
    Likes Received:
    0
    Joined:
    Oct 16, 2017
    Location:
    Washington State
    Ok so stupid question...? What’s the BCM? I’ve heard ecu etc before not BCM..? Thanks sorry lol
     
  4. MnFlyer

    MnFlyer Full Access Member

    Posts:
    136
    Likes Received:
    132
    Joined:
    Mar 26, 2019
    Location:
    MN
    Body Control Module.


    Sent from my iPhone using Tapatalk
     
  5. Sandfreak520

    Sandfreak520 Member

    Posts:
    20
    Likes Received:
    0
    Joined:
    Oct 16, 2017
    Location:
    Washington State
    Ok thanks looks like they are about $150-$200 bucks so cross my fingers that’s it thanks
     
  6. Sandfreak520

    Sandfreak520 Member

    Posts:
    20
    Likes Received:
    0
    Joined:
    Oct 16, 2017
    Location:
    Washington State
    Any ideas of where it’s located to replace? Can’t seem to find it under google search ? Thanks sorry
     
  7. MnFlyer

    MnFlyer Full Access Member

    Posts:
    136
    Likes Received:
    132
    Joined:
    Mar 26, 2019
    Location:
    MN
    No problem. It’s in the kick panel on the passenger side. Looks like a fuse block.


    Sent from my iPhone using Tapatalk
     
    tltoronto likes this.
  8. MTF

    MTF FRF Addict

    Posts:
    3,648
    Likes Received:
    911
    Joined:
    Nov 27, 2010
    Location:
    NYC
    Check battery, weak battery can do stupid stuff like that.

    Also check all battery to starter connections for loose terminal connections.
     
    Sage likes this.
  9. The Car Stereo Company

    The Car Stereo Company aka nosbusa Supporting Vendor

    Age:
    40
    Posts:
    24,925
    Likes Received:
    8,338
    Joined:
    Jul 8, 2012
    Location:
    here, on frf
    yes, the bcm is the entire fuse box assembly in the passenger side kick panel. i had a gen 1 come in with other issues, but similiar with lots of things not working. turned out that vibrations under hard acceleration and offroading were causing connection issues due to solder connections going bad.
     
  10. Sandfreak520

    Sandfreak520 Member

    Posts:
    20
    Likes Received:
    0
    Joined:
    Oct 16, 2017
    Location:
    Washington State
    Thanks guys plan to check battery and starter connections before dropping the money on the bcm will keep you posted later this weekend when I can diagnose it hopefully!
     

Share This Page