Help Support Ford Raptor Forum by donating:


Cam Phaser/ Engine Failure Poll

Discussion in 'Ford Raptor Engine Discussion and Performance Mods' started by Bhollier, May 19, 2019.

Have you had or have a cam phaser or engine failure on your Gen 2?

  1. Yes

    30.2%
  2. No

    65.5%
  3. I don't have a Raptor but will still vote and comment

    4.2%
Multiple votes are allowed.
  1. nikhsub1

    nikhsub1 FRF Addict

    Posts:
    1,776
    Likes Received:
    1,196
    Joined:
    Mar 5, 2017
    Unfortunately for you you got the same old phaser part that was prone to fail, and it failed again. The new part, IIRC, was introduced in 4/2019.
     
    Booth9999 likes this.
  2. FordTechOne

    FordTechOne Full Access Member

    Posts:
    1,055
    Likes Received:
    1,074
    Joined:
    Jul 29, 2019
    Location:
    Detroit
    Didn't you just get back from being banned for posting similar bullshit?
     
    Edbert and Donmatteo like this.
  3. FordTechOne

    FordTechOne Full Access Member

    Posts:
    1,055
    Likes Received:
    1,074
    Joined:
    Jul 29, 2019
    Location:
    Detroit
    You are describing 2 different issues.

    The cam phaser issue that was resolved in production mid-2018 only occurs on a cold start.

    If you are experiencing a noise concern unrelated to a cold start noise, it's something different. What year is your truck? A TSB was just released to address a cold start wastegate rattle on 2017s.
     
  4. FordTechOne

    FordTechOne Full Access Member

    Posts:
    1,055
    Likes Received:
    1,074
    Joined:
    Jul 29, 2019
    Location:
    Detroit
    I am not okay with someone spreading false information on a forum that exists to help owners and prospective buyers.
     
    Idaho, Donmatteo, Troutrad and 4 others like this.
  5. Brando

    Brando Full Access Member

    Posts:
    53
    Likes Received:
    6
    Joined:
    Jul 12, 2013
    Location:
    NW New Jersey
    28k miles and have been noticing it since for a month. Dealer ordered parts. Will post update.

    Sent from my SM-G965U using Tapatalk
     
  6. SVTTrooper

    SVTTrooper Full Access Member

    Posts:
    312
    Likes Received:
    288
    Joined:
    Aug 21, 2018
    Location:
    AB Canada
    Hope its resolved after this, nothing worse than it putting a bitter taste in your mouth if it becomes a reoccurring issue. I speak from experience lol.
     
    Brando likes this.
  7. Brando

    Brando Full Access Member

    Posts:
    53
    Likes Received:
    6
    Joined:
    Jul 12, 2013
    Location:
    NW New Jersey
    Sure hope not! Definitely has me thinking of moving on to a different truck!

    Sent from my SM-G965U using Tapatalk
     
  8. SVTTrooper

    SVTTrooper Full Access Member

    Posts:
    312
    Likes Received:
    288
    Joined:
    Aug 21, 2018
    Location:
    AB Canada
    Haha yeah that's why I have a Gen 1, sold my Gen 2 after 17K miles with phaser issues. If I were a Gen 2 owner now though.. I'd probably go for a Tremor... such a sweet truck.
     
  9. CR Gittere

    CR Gittere Full Access Member

    Posts:
    158
    Likes Received:
    56
    Joined:
    Apr 6, 2019
    Location:
    Charlotte
    Mine just started to rattle on start up, 2019 with 12,000 miles
     
  10. lawdog

    lawdog Full Access Member

    Posts:
    497
    Likes Received:
    151
    Joined:
    Mar 14, 2017
    Check your build date..my wife's '19 Expedition started doing it, too. Built in '18.

    I just had the repair done to my '18 Raptor...so far so good, but I really wish it hadn't needed to be done.
     

Share This Page