Help Support Ford Raptor Forum by donating:


Battery Keeps Dying

Discussion in 'Ford Raptor Problems and Questions Forum' started by Trav, Apr 24, 2015.

  1. Trav

    Trav Full Access Member

    Posts:
    73
    Likes Received:
    61
    Joined:
    Nov 20, 2014
    I just picked up a new to me bone stock 2013 Raptor SuoerCab 801a with 18000 miles on it.

    The battery keeps dying on it. The battery is new cause i wanted an AGM battery. Tho the issue was happening before i even replaced the battery.

    I have narrowed it down to a weird issue with the dash gauge cluster. THe clusters back lit light will intermittently come back on when the truck is parked turned off and remains on until it has drained my battery.

    I can easily reproduce the issue and will be taking it to Ford to see if they can get it taken care of.

    Wanted to see if anyone else has experienced this issue?
     
  2. Yukon Joe

    Yukon Joe FRF Addict

    Age:
    42
    Posts:
    18,359
    Likes Received:
    11,608
    Joined:
    Nov 16, 2011
    Location:
    Oak Island, NC
    Sounds strange. Hopefully the dealer can get it figured out.

    Yukon Joe
     
  3. CoronaRaptor

    CoronaRaptor FRF Addict

    Posts:
    15,367
    Likes Received:
    4,289
    Joined:
    Dec 17, 2012
    Location:
    CANADA
    Somebody else just had this issue on here!! Cant remember his name, he should pop in, hopefully.
     
  4. Bulletnjm

    Bulletnjm FRF Addict

    Posts:
    6,413
    Likes Received:
    3,815
    Joined:
    Mar 31, 2014
    Location:
    New Jersey
    I believe you are thinking of @mike.s but his was because of his whipple
     
  5. gDMJoe

    gDMJoe Full Access Member

    Posts:
    99
    Likes Received:
    46
    Joined:
    Oct 14, 2014
    Location:
    Timbuk3, MI
    Warranty: 3 Year / 36,000 Miles - Bumper / Bumper
    It's a common problem caused by a myriad of issues. .
     
    Beastalo, dhollist and Backinblack like this.
  6. Yukon Joe

    Yukon Joe FRF Addict

    Age:
    42
    Posts:
    18,359
    Likes Received:
    11,608
    Joined:
    Nov 16, 2011
    Location:
    Oak Island, NC
  7. mike.s

    mike.s Full Access Member

    Posts:
    974
    Likes Received:
    638
    Joined:
    May 12, 2012
    Yup, my Whipple supercharger was making contact with the positive terminal on the alternator.
     
  8. ESRaptor

    ESRaptor FRF Addict

    Posts:
    2,569
    Likes Received:
    236
    Joined:
    Mar 11, 2013
    Location:
    MD

    I have had a similar issue. After having it at the dealership three times, at that point, one morning I went out and the cluster was on. First time that it was observed by me. They got it back after that and I am still waiting for answers.


    Good luck. Here is my thread: http://www.fordraptorforum.com/f39/electrical-drain-41506/
     
  9. FordService

    FordService FRF Addict

    Posts:
    1,011
    Likes Received:
    507
    Joined:
    Feb 17, 2014
    Congrats on getting a Raptor, Trav! When are you heading in to have your dealership check out the battery issue? Come back and post when you have an update; I'm always just a PM away if you need my help after getting a diagnosis.

    Crystal
     
  10. Trav

    Trav Full Access Member

    Posts:
    73
    Likes Received:
    61
    Joined:
    Nov 20, 2014
    I plan on taking it in tomorrow. I just wanted to finish making the video documenting the issue. I will keep everyone posted.

     
    Last edited: Apr 27, 2015

Share This Page