Help Support Ford Raptor Forum by donating:


  1. Woolaroc

    Woolaroc Full Access Member

    Posts:
    168
    Likes Received:
    44
    Joined:
    Jul 16, 2019
    Location:
    Oklahoma
    Was doing some dirt road cruising in Baja Mode yesterday, which I've not used before and noticed on my dash the the Turbo gauge never moved. I got to a high way and kept it in Baja but changed to 2x4 and could see it go to about 1/4, not sure of the PSI b/c I didn't have that display up. Is this normal for Baja Mode, does it not engage the turbos as much?

    Also, this may be normal and I know it holds the RPMs higher before shift, but I'm about red line little over 7k before it shifts.
     
  2. smurfslayer

    smurfslayer Be vewwy, vewwy quiet. We’re hunting sasquatch77

    Posts:
    6,468
    Likes Received:
    4,405
    Joined:
    Dec 16, 2016
    Yes, this is normal. Baja holds higher rpms and boost so that when you are transitioning throttle you are back in the power band sooner.
     
  3. Woolaroc

    Woolaroc Full Access Member

    Posts:
    168
    Likes Received:
    44
    Joined:
    Jul 16, 2019
    Location:
    Oklahoma
    But if it’s holding higher boost shouldn’t I see the Turbo gauge registering a reading? It’s not showing anything 90% of the time and I don’t hear the turbos.
     
  4. jabroni619

    jabroni619 FRF Addict

    Posts:
    1,632
    Likes Received:
    941
    Joined:
    Jun 13, 2017
    Are you on the gas?
     
  5. VelociRap

    VelociRap Full Access Member

    Posts:
    77
    Likes Received:
    20
    Joined:
    May 16, 2019
    Location:
    Texas
    Personally i don’t like Baja mode, when running offroad track (unless muddy) i use RWD, TC off and manual shifting that way i have full control and you have to high rev unless you are doing sightseeing :)
     
  6. Booth9999

    Booth9999 FRF Addict

    Age:
    41
    Posts:
    1,369
    Likes Received:
    449
    Joined:
    Nov 19, 2017
    Location:
    Idyllwild
    Does it feel like there is power? With out the turbos it would fall on its face and really barely get to 50. I have used Baja a bunch in the sand but did not look at the gage. The truck it super aggressive in Baja, it seems like it would be noticeable....
     
  7. GCATX

    GCATX FRF Supporting Member Supporting Member

    Posts:
    1,114
    Likes Received:
    872
    Joined:
    Oct 6, 2018
    Location:
    Austin, TX
    I read somewhere, probably on here, that the only 2 modes that give full power are normal and sport. Not sure what net affect that would have on boost, but may be what's going on.
     
  8. pbtjrlmrt

    pbtjrlmrt Full Access Member

    Posts:
    338
    Likes Received:
    219
    Joined:
    Feb 21, 2019
    Location:
    Oregon
    As others have said...If you're not seeing anything registering on the boost gauge then you should also notice a substantial loss of power. If power is good then it might be a sensor or gauge. If power is off then one possibility would be that you have blown one of the hoses connecting the turbos to the IC. This actually happened to me after installing the AFE bladerunner IC. The clip holding on the hose fitting came off and the boost pushed the hose off. I immediately felt the loss of power and barely had any boost reading. Reattached the hose and all was good. Btw...I could tell the hose was off because with the windows down starting from a stop and flooring it I could hear the rush of air escaping the IC.
     
    Booth9999 likes this.
  9. Booth9999

    Booth9999 FRF Addict

    Age:
    41
    Posts:
    1,369
    Likes Received:
    449
    Joined:
    Nov 19, 2017
    Location:
    Idyllwild
    I don’t think that is accurate.
     
  10. Woolaroc

    Woolaroc Full Access Member

    Posts:
    168
    Likes Received:
    44
    Joined:
    Jul 16, 2019
    Location:
    Oklahoma
    Did a little testing this weekend and had the wife take some video of the dash.

    From a sitting start and about 1/2 to 3/4 throttle. I didn't smash the gas.




    This was in 5th gear and the Turbos really started to respond no matter the throttle input.



    I've noticed that if I don't SMASH the gas on the lower gears there is no turbo input and power is very low. If I go full throttle on the lower gears I do get turbo. Perhaps this is by design but Baja mode from gears 1-4 is lousy for power if you're not stepping on it HARD.
     

Share This Page