Help Support Ford Raptor Forum by donating:


GEN 2 at ~350 miles, multiple warnings / CEL, limp mode - back at dealer

Discussion in 'Ford F-150 Raptor General Discussions [GEN 2]' started by Asdjonasd, Sep 5, 2019.

  1. kskr

    kskr Member

    Posts:
    6
    Likes Received:
    2
    Joined:
    Mar 21, 2019
    Location:
    Kansas
    I thought the recommended oil was 5w30.
     
  2. FordTechOne

    FordTechOne Full Access Member

    Posts:
    136
    Likes Received:
    93
    Joined:
    Jul 29, 2019
    Location:
    Detroit
    Correct. 5W-30 Motorcraft Full Synthetic.
     
  3. smurfslayer

    smurfslayer Be vewwy, vewwy quiet. We’re hunting sasquatch77

    Posts:
    5,460
    Likes Received:
    3,520
    Joined:
    Dec 16, 2016
    That’s a new solenoid part number, FWIW
     
  4. kskr

    kskr Member

    Posts:
    6
    Likes Received:
    2
    Joined:
    Mar 21, 2019
    Location:
    Kansas
    According to the June 2019 Raptor Supplement it changed back to synthetic blend. The March 2019 printing had it as full synthetic.
     
  5. Johnkn

    Johnkn Full Access Member

    Posts:
    613
    Likes Received:
    342
    Joined:
    Nov 29, 2018
    Location:
    LaPlata, MD
    They put 5w-20 oil in it?
     
  6. smurfslayer

    smurfslayer Be vewwy, vewwy quiet. We’re hunting sasquatch77

    Posts:
    5,460
    Likes Received:
    3,520
    Joined:
    Dec 16, 2016
    Blackstone labs said mine, and all the 3.5TT’s they could remember were samples of 5/20 for the first sample.
     
  7. sixshooter_45

    sixshooter_45 Full Access Member

    Posts:
    361
    Likes Received:
    105
    Joined:
    Jun 17, 2012
    That's odd.
     
  8. FordTechOne

    FordTechOne Full Access Member

    Posts:
    136
    Likes Received:
    93
    Joined:
    Jul 29, 2019
    Location:
    Detroit
    Stick with full synthetic. Sounds like an issue with that printed version.
     

Share This Page