Help Support Ford Raptor Forum by donating:


GEN 1 Aftermarket 02 sensor??

Discussion in 'Ford Raptor Engine Discussion and Performance Mods' started by LIbraptor, May 26, 2019.

  1. LIbraptor

    LIbraptor Member

    Posts:
    13
    Likes Received:
    1
    Joined:
    Dec 24, 2017
    Hello all. My truck just threw a P0151 code today (Bank 2 sensor 1 low voltage). Wiring looks good, no exhaust leaks, and no other corresponding codes for a misfire etc.. so I am assuming my 02 has gone bad. (59,000 miles) my question is has anyone had any luck with aftermarket sensors from your local chain store??? (Denso, Bosh?) or am I stuck paying 200$ for one at ford?


    Sent from my iPhone using Tapatalk
     
  2. B E N

    B E N Full Access Member

    Posts:
    204
    Likes Received:
    93
    Joined:
    May 1, 2019
    Location:
    Frederick, CO
    I think they are like $70 through Tasca. Hard to beat the OEM quality, but I have run the Bosch aftermarket units on other vehicles with no problems.
     
  3. shoracer

    shoracer Member

    Posts:
    5
    Likes Received:
    0
    Joined:
    Aug 27, 2017
    Denso is usually the OEM for a lot of the modern Fords, so that is what I run in my Fords, my SC Boss 302 wears out O2 sensors pretty quick depending on how hard I am running the motor. Replace them often and never had an issue with a single one of the Denso.
     
  4. 1BAD454SSv2

    1BAD454SSv2 Full Access Member

    Posts:
    167
    Likes Received:
    155
    Joined:
    Jan 8, 2019
    Location:
    HELL I ZONA
    I run Denso with no issues . Motorcraft oem is made by bosch. Stick with those 3 and you will have no issues. Stay away from amazon /ebay crap or cheap chain store ones.
     

Share This Page