Help SupportFord Raptor Forum by donating:


Help support Ford Raptor Forum :

2014 engine missing

Discussion in 'Ford Raptor Engine Discussion and Performance Mods' started by Sooner89, Jul 2, 2019.

  1. Sooner89

    Sooner89 Member

    Posts:
    3
    Likes Received:
    0
    Joined:
    Jul 2, 2019
    Location:
    Houston, tx
    I have a 2014 raptor with 169,000 mile never had a problem. Replaced spark plugs at 160,000 miles. Today sitting at a stoplight first thing in the morning the engine started missing. I thought I just got a bad slug of gas, so I drove it to a Shell station and filled the tank. After 30 minutes engine still missing. Drove to Oreilys to check codes. Codes came back as cylinder 7 and 8 bad ignition. I have order 2 new coils and a full set of plug wires. What else should I look into?

    Thanks in advance
     
  2. raisins

    raisins FRF Supporting Member Supporting Member

    Posts:
    134
    Likes Received:
    34
    Joined:
    Jan 30, 2017
    Location:
    NJ
    I think that's a good start. Coil packs, new plugs (make sure they are correctly gapped) and new plug wires.
     
  3. Sernas

    Sernas Member

    Age:
    28
    Posts:
    39
    Likes Received:
    13
    Joined:
    Jun 18, 2017
    Broken valve spring?
     
  4. 500mag

    500mag FRF Supporting Member Supporting Member

    Posts:
    159
    Likes Received:
    64
    Joined:
    Mar 22, 2019
    Location:
    Georgia
    Where did it go?
     
  5. Sooner89

    Sooner89 Member

    Posts:
    3
    Likes Received:
    0
    Joined:
    Jul 2, 2019
    Location:
    Houston, tx
    Update..
    Broken valve springs on cylinder 8. At the shop should be fixed by Thursday. Compression still good. Let's see on Thursday.
     
  6. Shinocu

    Shinocu Full Access Member

    Age:
    28
    Posts:
    67
    Likes Received:
    23
    Joined:
    Apr 28, 2013
    Location:
    Wilmington nc
    you have 170K on a 14?:eek:
     
    Swacer likes this.
  7. Swacer

    Swacer Full Access Member

    Posts:
    185
    Likes Received:
    54
    Joined:
    Dec 5, 2012
    Location:
    PA
    I was thinking the same thing. Got a '14 with 52k and its my daily driver. lol
     
  8. MEIRONMAN207

    MEIRONMAN207 Member

    Posts:
    28
    Likes Received:
    8
    Joined:
    Jun 26, 2019
    Location:
    Maine
    Wow...I have that kinda mileage on my ‘04...and that is driving up and back the East Coast several times a year.
     
  9. Sooner89

    Sooner89 Member

    Posts:
    3
    Likes Received:
    0
    Joined:
    Jul 2, 2019
    Location:
    Houston, tx
    Well I got my Raptor back on Friday. Cost $950. Mechanic says the rest of the engine looks good. Yes, I have 170,000, I live in a Houston suburb and drive close to 150 miles every day. My truck has always had royal purple oil and k&n oil filters. I keep it very well mantained and plan on driving it for another 100,000 miles.

    Why is it always the #8 spring that breaks? At least the is the one that others have posted that broke.

    Thanks
     
  10. Shinocu

    Shinocu Full Access Member

    Age:
    28
    Posts:
    67
    Likes Received:
    23
    Joined:
    Apr 28, 2013
    Location:
    Wilmington nc
    its awesome to hear the motors last. as long as you take care of it.
     

Share This Page