Help SupportFord Raptor Forum by donating:


Help support Ford Raptor Forum :

2013 Raptor - Engine Fan runs at high speed after PCM update for recall

Discussion in 'Ford Raptor Problems and Questions Forum' started by amstilwell, Jul 9, 2019.

  1. amstilwell

    amstilwell Member

    Posts:
    3
    Likes Received:
    0
    Joined:
    Feb 19, 2014
    Took my 2013 Raptor SCREW in for this recent safety recall 19S07 which they corrected with a PCM update and ever since the engine fan runs at high speed when the engine is first started (cold) and at random times. Very loud and annoying. It's so loud have to cut off the motor when in a drive thru. Almost 100k on the truck and never did this till now.

    Took it back to my local dealer and they said is part of ford's new strategy and was intentional. Really hard to believe as its just too darn loud. Any else seeing this after the 19S07 PCM update?

    I'm wondering if it might also be a bad TXV valve or clutch fan.

    Any suggestions?

    Thanks,
    Allen
     
  2. MEIRONMAN207

    MEIRONMAN207 Member

    Posts:
    28
    Likes Received:
    8
    Joined:
    Jun 26, 2019
    Location:
    Maine
    Yes. When I first took my home I noticed that the rad fan kicked on and sounded like a chopper was about to take off!
    Searched around on the net for similar issues/problems before I joined this forum. Found out it’s a common annoyance.
     
  3. tipnring

    tipnring Full Access Member

    Posts:
    530
    Likes Received:
    169
    Joined:
    Oct 15, 2012
    Location:
    Jacksonville Beach, Fla
    I've noticed this happening on mine lately too. I wonder what's up with that.
     

Share This Page