Go Back   FORD RAPTOR FORUM - Ford SVT Raptor Forums - Ford Raptor > Ford Raptor Forums - General Information > Ford Raptor Problems and Questions Forum
Become a Supporting Member         Become a Supporting Vendor

Register to remove these ads.


Ford Raptor Problems and Questions Forum

Transmission issues


This is a discussion on Transmission issues within the Ford Raptor Problems and Questions Forum forums, part of the Ford Raptor Forums - General Information category!
I also heard change fluid regularly or never do it. Also never do a flush. I have changed mine every ...


User Tag List

Like Tree6Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 01-28-2016, 11:19 PM   #11 (permalink)
Banned

 
Join Date: Jul 2015
Location: HELL Arizona 6.2L There is more to life than gas mileage
Age: 46
Posts: 136
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)

Default
I also heard change fluid regularly or never do it. Also never do a flush. I have changed mine every 25,000 miles , just drop pan and change filter , also a transfer case drain and refill at same time. Coming up on my 75,000 mile ,waiting for dealer to call on some warranty parts for seat. When those come in , i will have them change fluid and filter and transfer case. I have a aftermarket dipstick and fluid is still cherry red . Hard miles too and 45,000 of the those are supercharged. I have the Afe trans pan and cbr trans cooler also so that help keep fluid from getting hot.

---------- Post added at 08:19 PM ---------- Previous post was at 08:11 PM ----------

You might try a KAM reset , i did it through my SCT tuner , and it seems to erase everything vs. the battery disconnect method. After i did that KAM reset it took about 50 miles for trans to relearn shifting and line pressures. If i hadnt of just drove my truck right before doing a KAM reset i would of thought the trans was toasted. The shifting was real goofy and every shift it would rev up and delayed shift. Just drove it easy stop and go and every shift started getting better and better and the shifts feel really good now.





Last edited by BAD454SS; 01-28-2016 at 11:49 PM.
BAD454SS is offline   Reply With Quote
Old 02-01-2016, 08:58 PM   #12 (permalink)
 
Jfreeze's Avatar
Junior Member

 
Join Date: Feb 2013
Age: 42
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
Thanks for all of your input. The truck is at the dealership where I bought it. I should hear something back soon as far as what the heck is wrong and let all you guys know.
CoronaRaptor likes this.
Jfreeze is offline   Reply With Quote
Old 02-10-2016, 11:30 AM   #13 (permalink)
 
Jfreeze's Avatar
Junior Member

 
Join Date: Feb 2013
Age: 42
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
Update
My truck has been at the dealership for 1.5 weeks now. Diagnosed as bad TB, not that & then as bad PCM, replaced PCM & the truck is no better & apparently going into limp mode now. The truck is bone stock. Dealership waiting on a response from Ford, my fear is that this could go on for weeks & I need a freaking vehicle!
Jfreeze is offline   Reply With Quote
Old 02-10-2016, 03:53 PM   #14 (permalink)
 
whoisbigman's Avatar
Full Access Member

 
Join Date: Dec 2013
Location: Palm Beach Florida
Age: 52
Posts: 509
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)

Default
Since they can't figure it out, why not take your truck back now that it's a documented issue, thrash the shit out of it till the tranny drops out for real, and give them something to work with.


__________________
2012 Tux Black, Loaded. Previous owner added Spray-in liner, bed cover, LED everything, AFE intake, Magnaflow Exhaust, mid-perch... other stuff I haven't found yet. Thank You whoever you are... I have added 37" Nitto tires, painted speaker grilles, Roush vacuum gauge for hubs.
whoisbigman is offline   Reply With Quote
Old 02-10-2016, 04:12 PM   #15 (permalink)
 
t_j's Avatar
t_j
FRF Addict

 
Join Date: Sep 2013
Location: Chicago, IL
Posts: 2,667
Mentioned: 238 Post(s)
Tagged: 0 Thread(s)

Default
Still going with the valve body!
t_j is offline   Reply With Quote
Old 02-11-2016, 03:57 PM   #16 (permalink)
 
Jfreeze's Avatar
Junior Member

 
Join Date: Feb 2013
Age: 42
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
Dropping the pan today to check the Megatronics (valve body) today. I agree that's probably the culprit. Not throwing any codes, so it must be something mechanical. I will keep y'all posted.......


__________________
Jason
Jfreeze is offline   Reply With Quote
Old 02-16-2016, 12:36 PM   #17 (permalink)
 
Jfreeze's Avatar
Junior Member

 
Join Date: Feb 2013
Age: 42
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
Valve body checked out ok. Pulling transmission now, suspect is now the Forward Clutch assembly. Yesterday was 2 weeks.....This is starting to get Real! Will keep y'all posted
Jfreeze is offline   Reply With Quote
Old 02-19-2016, 11:52 AM   #18 (permalink)
 
Jfreeze's Avatar
Junior Member

 
Join Date: Feb 2013
Age: 42
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
I want everyone to know that my truck is fixed and better than ever. I also want to Thank Crystal (She's a superstar) for all of the help & support she provided me in getting this resolved. I also want to thank everyone that was responding & or monitoring this thread. Soooo.......
To settle any bets the culprit ended up being the forward clutch assembly. Congratulations to FORD for stepping up & creating a customer for LIFE!! I'm so pleased.
Jfreeze is offline   Reply With Quote
Old 02-22-2016, 03:35 PM   #19 (permalink)
 
FordService's Avatar
Ford Professional

 
Join Date: Feb 2014
Posts: 1,011
Mentioned: 136 Post(s)
Tagged: 0 Thread(s)

Default
Originally Posted by Jfreeze View Post
I want everyone to know that my truck is fixed and better than ever. I also want to Thank Crystal (She's a superstar) for all of the help & support she provided me in getting this resolved. I also want to thank everyone that was responding & or monitoring this thread. Soooo.......
To settle any bets the culprit ended up being the forward clutch assembly. Congratulations to FORD for stepping up & creating a customer for LIFE!! I'm so pleased.
Glad to read this was resolved for you, Jfreeze! :) You know where to find us should you ever need anything down the road.

Nick


__________________
FORD SERVICE

p: 800.392.FORD
t: @FordService @FordTrucks @Ford
f: facebook.com/FordTrucks facebook.com/Ford
FordService is offline   Reply With Quote
Reply

Bookmarks


Tags
dead pedal, hard shifts, problems, transmission

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
TSB 11-3-25 - Transmission bulkhead connector sleeve leaking transmission fluid pirate air Ford Raptor Recalls | TSB's | SSM's 8 04-17-2016 03:54 PM
2010 Transmission Issues *jrwiii* Ford Raptor Problems and Questions Forum 0 06-11-2013 11:32 AM
4L transmission issues brusso99 2012 Ford SVT Raptor Forum (Reply Only) 21 09-06-2012 08:52 PM
Transmission issues Hocker52 Ford Raptor Problems and Questions Forum 21 04-11-2012 06:22 PM
Raptor transmission issues Dizzytablet Ford Raptor Problems and Questions Forum 48 06-15-2011 04:07 PM



GM Truck Forum
Chevy Tahoe Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Tahoe Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Land Rover Forum
Scion FR-S Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum