Go Back   FORD RAPTOR FORUM - Ford SVT Raptor Forums - Ford Raptor > Ford Raptor Forums - General Information > Ford Raptor Problems and Questions Forum
Become a Supporting Member         Become a Supporting Vendor

Register to remove these ads.


Ford Raptor Problems and Questions Forum

Ford Raptor Fuel Pump Fuse Issue


This is a discussion on Ford Raptor Fuel Pump Fuse Issue within the Ford Raptor Problems and Questions Forum forums, part of the Ford Raptor Forums - General Information category!
Is there any other fuses or relays other than the relay under the hood and on the cross member by ...


User Tag List

Like Tree209Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 12-30-2014, 03:26 PM   #1 (permalink)
Junior Member

 
Join Date: Jan 2013
Age: 33
Posts: 13
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default Ford Raptor Fuel Pump Fuse Issue
Is there any other fuses or relays other than the relay under the hood and on the cross member by the spare tire? I've changed both of those and the fuel pump but my truck still will not start.

I've tried both keys, unhooked the battery for over an hour and even tried changing tunes but still no luck. It will turn over but not fire off, when i turn the key on i don't hear anything coming from the fuel pump.

It's a 2011 Screw with 116k miles on it. Only performance mods are SCT livewire TS and AFE cold air intake.




billybob974 is offline   Reply With Quote
Old 12-30-2014, 06:40 PM   #2 (permalink)
 
Rookie's Avatar
FRF Addict


 
Join Date: Dec 2012
Location: Fort Wayne, IN
Posts: 9,750
Mentioned: 354 Post(s)
Tagged: 5 Thread(s)

Default
Have you tried metering at the fuel pump to see if it's getting juice?


freedommotorsports.us

Phone: 260-444-7503
Email: [email protected]



RPG likes this.
Rookie is offline   Reply With Quote
Old 12-31-2014, 01:04 PM   #3 (permalink)
 
MTF's Avatar
MTF
FRF Addict

 
Join Date: Nov 2010
Location: NYC
Age: 56
Posts: 3,152
Mentioned: 64 Post(s)
Tagged: 0 Thread(s)

Default
Our fuel system does not have a return line, so when the fuel pressure is achieved the pump will shut down.
If the truck has been off for a while, and you turn the key the pump may run for a few seconds before pressure is achieved.
And I've tried but I can't hear it run on first turn of the key in the morning and I upgraded my fuel pump to a larger capacity one.
There are a few threads about cranking and not starting, do a search using the search tab on the forum not the internet.
It seems the alarm is the most likely suspect, then the BCM. From what I've been reading.

I believe I never heard of a fuel pump failing!!!

Have you done a spark test?
Any codes showing on your Tuner tool?

Do you have both keys and fob's?
Replace batteries and try starting with both keys next to the steering column.


__________________
Whipple 700+ HP Upgrade Package, Oil and Fuel pump upgrades, Custom Deavers +2 Rear Springs, Axle Exchange Driveshaft, Rogue Racing Traction Bars, Hellwig rear sway bar, Pace Edward electric bed cover with remote, Pop & Lock Tail Gate lock, Mud Flaps, Window Rain Guards, EZ Down Tailgate, Bed Rug,
Future Installs: Brembo Brakes 15" Gran Turismo

Last edited by MTF; 12-31-2014 at 01:22 PM.
MTF is online now   Reply With Quote
Old 12-31-2014, 05:20 PM   #4 (permalink)
 
J DAMAGE's Avatar
Full Access Member

 
Join Date: Jul 2012
Location: NJ
Age: 48
Posts: 745
Mentioned: 21 Post(s)
Tagged: 0 Thread(s)

Default
Also check the fuel control module.
MTF likes this.
J DAMAGE is offline   Reply With Quote
Old 12-31-2014, 07:20 PM   #5 (permalink)
Junior Member

 
Join Date: Jan 2013
Age: 33
Posts: 13
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
Have you tried metering at the fuel pump to see if it's getting juice? No I haven't tried that, I'm not so good with the electrical side of things.

Our fuel system does not have a return line, so when the fuel pressure is achieved the pump will shut down. When i pulled the tank to change the pump, fuel drained out of the lines where I disconnected them at the front of the tank. I was thinking since this happened, once i had everything back together I should've heard the pump kick on to build pressure.

Have you done a spark test? To see if it's getting spark at the plugs? No i haven't.

Any codes showing on your Tuner tool? No, I scanned it even though its not throwing a CEL.

Do you have both keys and fob's?
Replace batteries and try starting with both keys next to the steering column. Yeah i did that. Tried both keys in the ignition and by remote start.

Also check the fuel control module. Yeah i changed that too after changing pump didn't fix anything.

I'm just going to bring it to my mechanic down the road this weekend so he can hook it up to the proper computer and tell me whats going on. It just baffles me that it was driving fine one day then the next day it won't start.
billybob974 is offline   Reply With Quote
Old 12-31-2014, 07:37 PM   #6 (permalink)
 
J DAMAGE's Avatar
Full Access Member

 
Join Date: Jul 2012
Location: NJ
Age: 48
Posts: 745
Mentioned: 21 Post(s)
Tagged: 0 Thread(s)

Default
You could try something easy to narrow it down to fuel problem or spark problem, but dont get crazy, you could give it a hit of starting fluid, pop the air tube off at the throttle body, just a small hit to see if it fires on the starting fluid, if it does you have a electrical problem or connection going to the fuel pump, if it doesn't fire on the starter fluid, you have no spark.

Last edited by J DAMAGE; 01-05-2015 at 08:55 PM.
J DAMAGE is offline   Reply With Quote
Old 12-31-2014, 07:45 PM   #7 (permalink)
Junior Member

 
Join Date: Jan 2013
Age: 33
Posts: 13
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
Originally Posted by J DAMAGE View Post
You could try something easy to narrow it down to fuel problem or spark problem, but dont get crazy, you could give it a hit of starter fluid, pop the air tube off at the throttle body, just a small hit to see if it fires on the starter fluid, if it does you have a electrical problem or connection going to the fuel pump, if it doesn't fire on the starter fluid, you have no spark.
Ok cool, I never even thought of trying it that way. I'll give that a shot tomorrow...well depending on how tonight goes I might be too hungover and it'll have to wait until friday.
billybob974 is offline   Reply With Quote
Old 12-31-2014, 07:48 PM   #8 (permalink)
 
J DAMAGE's Avatar
Full Access Member

 
Join Date: Jul 2012
Location: NJ
Age: 48
Posts: 745
Mentioned: 21 Post(s)
Tagged: 0 Thread(s)

Default
Originally Posted by billybob974 View Post
Ok cool, I never even thought of trying it that way. I'll give that a shot tomorrow...well depending on how tonight goes I might be too hungover and it'll have to wait until friday.
Just be light on it, so you don't possably flash back yourself, you could also use a spray bottle with gas, but caution bottle may get soft and leak with gas in it.
J DAMAGE is offline   Reply With Quote
Old 12-31-2014, 07:52 PM   #9 (permalink)
Junior Member

 
Join Date: Jan 2013
Age: 33
Posts: 13
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
Originally Posted by J DAMAGE View Post
Just be light on it, so you don't possably flash back yourself, you could also use a spray bottle with gas, but caution bottle may get soft and leak with gas in it.
Yeah I've had that happen to me before in other applications. Red solo cups get soft pretty quick too!
billybob974 is offline   Reply With Quote
Old 12-31-2014, 08:16 PM   #10 (permalink)
 
J DAMAGE's Avatar
Full Access Member

 
Join Date: Jul 2012
Location: NJ
Age: 48
Posts: 745
Mentioned: 21 Post(s)
Tagged: 0 Thread(s)

Default
Originally Posted by billybob974 View Post
Yeah I've had that happen to me before in other applications. Red solo cups get soft pretty quick too!
Just take caution, best of luck to you, have a great new year.

Last edited by J DAMAGE; 12-31-2014 at 08:24 PM.
J DAMAGE is offline   Reply With Quote
Reply

Bookmarks


Tags
fuel pump fuse, won't start"

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2013 Raptor would not start - fuel pump? BearLeeAsian Ford Raptor Maintenance Forum 44 06-19-2017 11:59 AM
Fuel Pump Module jlauth Ford Raptor Problems and Questions Forum 3 04-14-2015 09:12 PM
Fuel pump kit upgrade metronyc Livernois Motorsports 21 03-21-2015 06:36 PM
Livernois Motorsports & Engineering Ford Raptor Fuel Pump Upgrade Kit Livernois Motorsports Ford Raptor Engine Discussion and Performance Mods-6.2 Liter V8 [GEN 1] 21 08-05-2014 10:13 PM
Blowen fuse for fuel system PlyRok Ford Raptor Problems and Questions Forum 0 04-30-2014 09:39 PM



GM Truck Forum
Chevy Tahoe Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Tahoe Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Land Rover Forum
Scion FR-S Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum