Go Back   FORD RAPTOR FORUM - Ford SVT Raptor Forums - Ford Raptor > Ford Raptor Forums - General Information > Ford Raptor Problems and Questions Forum
Become a Supporting Member         Become a Supporting Vendor

Register to remove these ads.


Ford Raptor Problems and Questions Forum

engine Cut-off and low oil pressure warning!!


This is a discussion on engine Cut-off and low oil pressure warning!! within the Ford Raptor Problems and Questions Forum forums, part of the Ford Raptor Forums - General Information category!
Replaced it on mine a couple months ago. Installed a oil pressure gauge at the same time. I first got ...


User Tag List

Like Tree31Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 09-16-2016, 01:59 PM   #141 (permalink)
 
jef's Avatar
jef
Full Access Member

 
Join Date: Mar 2014
Location: belgium
Age: 35
Posts: 237
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)

Default
Replaced it on mine a couple months ago. Installed a oil pressure gauge at the same time. I first got the oil pressure low alarm once a day, after a couple days it was every 10 seconds.




jef is offline   Reply With Quote
Old 09-16-2016, 06:12 PM   #142 (permalink)
 
BearLeeAsian's Avatar
FRF Addict

 
Join Date: Oct 2013
Location: Dallas Texas
Posts: 3,401
Mentioned: 119 Post(s)
Tagged: 0 Thread(s)

Default
Originally Posted by jef View Post
Replaced it on mine a couple months ago. Installed a oil pressure gauge at the same time. I first got the oil pressure low alarm once a day, after a couple days it was every 10 seconds.

Guessing it helped? Lol

Same part?


Sent from my iPhone using Tapatalk


__________________
12 Hennessey Velociraptor 600
BearLeeAsian is offline   Reply With Quote
Old 09-16-2016, 11:38 PM   #143 (permalink)
 
jef's Avatar
jef
Full Access Member

 
Join Date: Mar 2014
Location: belgium
Age: 35
Posts: 237
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)

Default
[QUOTE=BearLeeAsian;1035168]Guessing it helped? Lol

Same part?


Sent from my iPhone using Tapatalk

Same part and didn't get the message again.
I replaced the sensor without removing the skidplates. Not the smartest way to do it.
jef is offline   Reply With Quote
Old 09-09-2017, 02:27 PM   #144 (permalink)
Full Access Member

 
Join Date: Jan 2017
Posts: 186
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default
Wife and kid was out in my truck and making a slow left hand turn in intersection truck died, no power steering and LOP. She was upset and scared and tried to push truck as it wouldn't start in middle of intersection then got it to kick over. Came home scared and upset. I checked the truck over, drove it, checked for codes and no issues and all was fine. Truck is a 2013 with 40k miles and has a Roush/VMP blower tune for last 5k miles.
biturbomg is offline   Reply With Quote
Old 10-18-2017, 04:12 PM   #145 (permalink)
Junior Member

 
Join Date: Oct 2017
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default
Got to express my gratitude for this site being here, for 305raptor post, and the 86 cent answer to an imagined expensive nightmare.

Had the "engine dies with low oil pressure warning" issue several times before idiot check engine light also lit up. Expected to take it to Ford dealer to learn of any error codes, spend lots of money, etc.

But the mention of fuse #27 by 305raptor saved my bacon. Was burned but couldn't tell if it was allowing current through, but since replacing it...no problems whatsoever! Who'd of thunk a $.86 fuse would resolve all issues with my "high dollar" truck. As we say in TX...yeeehaaaaa!

But while I'm here, had my ac/heater fan motor start making noise, thought rats or snake would be found as we live in rural area, but when mechanic walked in with this, no one knew what it was or where it came from. Anybody here recognize it?
Attached Thumbnails
raptfan.jpg   raptfan1.jpg  
'Smith is offline   Reply With Quote
Old 01-10-2018, 11:54 PM   #146 (permalink)
 
Raptized's Avatar
Full Access Member

 
Join Date: Dec 2016
Location: Raptorida
Posts: 474
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)

Default
2013 Ford Raptor SuperCrew 27953 miles Oil change 2 months ago. Oil life still at 69%. I went with the recommended Ford Motor Company synthetic and Ford Motor Company oil filter. I was on my way home from work about 10 minutes into the drive. I went to take off from a stop light and I got through the intersection and had an immediate reduction in power the truck was stuck at 1,000 RPMs and would not do anything but slowly creep forward at 5 miles an hour I limped to a lighted parking lot about a half block away as my low oil pressure light came on and a wrench icon on the dash I shut it off popped open the hood I check my oil level transmission fluid level power steering level and everything was well above tolerances I could find no problems and when I got back in the truck and started it it ran fine all the way home also just scan the system and no error codes so are you saying that all of these problems are the result of a bad fuse?


__________________
ďAre you guys silly? Iím still gonna send it!Ē Larry Enticer
Build Thread: http://www.fordraptorforum.com/f65/raptized-build-thread-57299/
Raptized is offline   Reply With Quote
Old 01-11-2018, 10:38 AM   #147 (permalink)
Junior Member

 
Join Date: Oct 2017
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default
Youbetcha! Spent $.86 for my #27 at wallyworld and haven't had a problem since. May be an underlying issue I should have addressed, but truck runs as good as ever, no problems, changed oil once since then, and still no problems. Use some caution removing #27 as mine was burnt/brittle and came out in pieces.
'Smith is offline   Reply With Quote
Old 01-11-2018, 02:41 PM   #148 (permalink)
 
Raptized's Avatar
Full Access Member

 
Join Date: Dec 2016
Location: Raptorida
Posts: 474
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)

Default
Originally Posted by 'Smith View Post
Got to express my gratitude for this site being here, for 305raptor post, and the 86 cent answer to an imagined expensive nightmare.

Had the "engine dies with low oil pressure warning" issue several times before idiot check engine light also lit up. Expected to take it to Ford dealer to learn of any error codes, spend lots of money, etc.

But the mention of fuse #27 by 305raptor saved my bacon. Was burned but couldn't tell if it was allowing current through, but since replacing it...no problems whatsoever! Who'd of thunk a $.86 fuse would resolve all issues with my "high dollar" truck. As we say in TX...yeeehaaaaa!

But while I'm here, had my ac/heater fan motor start making noise, thought rats or snake would be found as we live in rural area, but when mechanic walked in with this, no one knew what it was or where it came from. Anybody here recognize it?
Low pressure cap aka service cap aka charging valve cap for a/c?


__________________
ďAre you guys silly? Iím still gonna send it!Ē Larry Enticer
Build Thread: http://www.fordraptorforum.com/showthread.php?t=57299

Last edited by Raptized; 01-11-2018 at 02:49 PM.
Raptized is offline   Reply With Quote
Old 01-12-2018, 01:33 PM   #149 (permalink)
 
Raptized's Avatar
Full Access Member

 
Join Date: Dec 2016
Location: Raptorida
Posts: 474
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)

Default
Well f $&# me. Fuse is trashed. How freaking dangerous. This seems like something I will get a letter in the mail for for a class action suit after enough people die.


__________________
ďAre you guys silly? Iím still gonna send it!Ē Larry Enticer
Build Thread: http://www.fordraptorforum.com/showthread.php?t=57299
Raptized is offline   Reply With Quote
Old 01-12-2018, 03:13 PM   #150 (permalink)
Full Access Member

 
Join Date: Oct 2015
Posts: 164
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)

Default
This is such a common and potentially stranding issue. Makes me glad I went ahead and proactively changed this flawed set up and fixed with the fuel pump fuse relocation mod.
03Cobraraptor is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sand air down pressure? whtrapta Ford Raptor Wheels & Tires Forum [GEN 1] 45 06-13-2012 06:55 PM
Too much pressure... giffordt New Member Check-In 18 03-18-2011 07:41 AM



GM Truck Forum
Chevy Tahoe Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Tahoe Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Land Rover Forum
Scion FR-S Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum