Go Back   FORD RAPTOR FORUM - Ford SVT Raptor Forums - Ford Raptor > Ford Raptor Forums - General Information > Ford Raptor Problems and Questions Forum
Become a Supporting Member         Become a Supporting Vendor

Register to remove these ads.


Ford Raptor Problems and Questions Forum

abs/brake light/hill descent warning lights going off


This is a discussion on abs/brake light/hill descent warning lights going off within the Ford Raptor Problems and Questions Forum forums, part of the Ford Raptor Forums - General Information category!
Anybody else had this issue?. Started it up the other day and after a few minutes of driving the dash ...


User Tag List

Like Tree1Likes
  • 1 Post By All The Way

Reply
 
LinkBack Thread Tools Display Modes
Old 05-05-2014, 08:58 PM   #1 (permalink)
 
cubiefan101's Avatar
Full Access Member

 
Join Date: Oct 2012
Location: Illinois
Posts: 385
Mentioned: 29 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default abs/brake light/hill descent warning lights going off
Anybody else had this issue?. Started it up the other day and after a few minutes of driving the dash began to go nuts chiming four times and showing the brake light, abs light and hill decent warning light with it stating to check braking system. Also when throughout these errors it won't allow me to use hill descent or off road mode. Any ideas?




cubiefan101 is offline   Reply With Quote
Old 05-05-2014, 09:12 PM   #2 (permalink)
 
All The Way's Avatar
FRF Addict

 
Join Date: Sep 2011
Location: Lockport, NY
Age: 36
Posts: 1,871
Mentioned: 21 Post(s)
Tagged: 0 Thread(s)

Default
third break light or a wheel speed sensor


All The Way is offline   Reply With Quote
Old 05-05-2014, 09:20 PM   #3 (permalink)
 
Huck's Avatar
FRF Addict


 
Join Date: Aug 2012
Location: Chicago Sw Burbs
Age: 35
Posts: 4,057
Mentioned: 85 Post(s)
Tagged: 1 Thread(s)

Default
^^ what he said. I had it happen with an abs speed sensor go bad. But no abs in the snow is a blast


Sent from my iPhone using Tapatalk


__________________
Icom F5021,RPG Stg 4+ Fox 3.0 coilovers, RPG Tie-rods (modified to camburg hardware), RPG PS reservoir, Camburg 1.25" UCA's , Raptor -Retro fit '13 HIDS, Line-x preminum, Bluewater LED bed lights, Ipad mini navigation. Bubba rope. Rollx, Recon 10.5k winch synth rope, factor 55, SVC Custom acuated tower. Visions 30" xmitter extreme, 35" toyo MT, visionx 6550 spot.
Huck is offline   Reply With Quote
Old 05-05-2014, 09:30 PM   #4 (permalink)
 
cubiefan101's Avatar
Full Access Member

 
Join Date: Oct 2012
Location: Illinois
Posts: 385
Mentioned: 29 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
Im thinking abs sensor too. If checked the third brake light and put rtv adhesive around the gasket already so it should be good.
cubiefan101 is offline   Reply With Quote
Old 05-05-2014, 09:40 PM   #5 (permalink)
 
Huck's Avatar
FRF Addict


 
Join Date: Aug 2012
Location: Chicago Sw Burbs
Age: 35
Posts: 4,057
Mentioned: 85 Post(s)
Tagged: 1 Thread(s)

Default
check the rear sensors, they can be easily damaged.


__________________
Icom F5021,RPG Stg 4+ Fox 3.0 coilovers, RPG Tie-rods (modified to camburg hardware), RPG PS reservoir, Camburg 1.25" UCA's , Raptor -Retro fit '13 HIDS, Line-x preminum, Bluewater LED bed lights, Ipad mini navigation. Bubba rope. Rollx, Recon 10.5k winch synth rope, factor 55, SVC Custom acuated tower. Visions 30" xmitter extreme, 35" toyo MT, visionx 6550 spot.
Huck is offline   Reply With Quote
Old 05-06-2014, 01:44 AM   #6 (permalink)
 
Raptor Embroidery's Avatar
aka Raptor_Al_41

 
Join Date: Jan 2012
Location: Scottsboro, Alabama
Age: 24
Posts: 3,961
Mentioned: 63 Post(s)
Tagged: 0 Thread(s)

Default
Once you get it fixed (if it is abs) wrap the abs lines and get abs guards from one of our vendors (Sdhq outlaw etc)

Sent from my XT1080 using Tapatalk


__________________

www.raptorcustomembroidery.com
Call/text - 256-599-6040 Email - [email protected]
Leather wrapped center consoles, embroidery and laser engraving.
Raptor Embroidery is offline   Reply With Quote
Old 12-23-2014, 09:47 PM   #7 (permalink)
 
8WOOD's Avatar
Full Access Member

 
Join Date: Oct 2014
Posts: 220
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)

Default
Don't want to make a new thread so I thought I'd revive this one.

I just had a rock flip up and cut my ABS wire in half on the rear. I got all the indications previously explained in the first post. I spliced the wires back together and was wondering if there's a trick to clearing the codes? Unplug the battery? Or do I have to have a OBDII tool?

If anyone knows it would be great info. Thanks

***UPDATE***

I figured it out. I don't know how, but I started turning the traction control button on and off and it suddenly said advance trac enable and then everything worked again. It must have auto reset or I pushed the traction button enough times to reset the system.

Last edited by 8WOOD; 12-23-2014 at 10:48 PM.
8WOOD is offline   Reply With Quote
Old 12-24-2014, 12:08 AM   #8 (permalink)
 
All The Way's Avatar
FRF Addict

 
Join Date: Sep 2011
Location: Lockport, NY
Age: 36
Posts: 1,871
Mentioned: 21 Post(s)
Tagged: 0 Thread(s)

Default
Mine cleared right away. 2010 Scab 6.2
Its fun to unplug one during the winter time.
lka likes this.


All The Way is offline   Reply With Quote
Old 08-06-2016, 05:11 PM   #9 (permalink)
Junior Member

 
Join Date: May 2012
Location: Richmond va
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default brake warning light frozen pedal. clears
driving 70 on pa turnpike. 2011 screw. red brake warning comes on. press brake pedal hard as rock no braking! pressed again, felt pulsations like abs. then pedal clears and pushes. normal braking. warning light stays on. got off turnpike. check all wheels and reservoir. all good no leaks. braking normal. stopped vehicle for an hour. warning light cleared on restart. ford dealer reveals no faults or abnormalities. suspect sticking vacuum assist valve which is backed up by abs. drove 500 miles since. no issues. any body experience??
JBronius is offline   Reply With Quote
Old 08-06-2016, 05:37 PM   #10 (permalink)
 
Yukon Joe's Avatar
FRF Addict

 
Join Date: Nov 2011
Location: Oak Island, NC
Age: 40
Posts: 18,224
Mentioned: 567 Post(s)
Tagged: 13 Thread(s)

Default
Originally Posted by JBronius View Post
driving 70 on pa turnpike. 2011 screw. red brake warning comes on. press brake pedal hard as rock no braking! pressed again, felt pulsations like abs. then pedal clears and pushes. normal braking. warning light stays on. got off turnpike. check all wheels and reservoir. all good no leaks. braking normal. stopped vehicle for an hour. warning light cleared on restart. ford dealer reveals no faults or abnormalities. suspect sticking vacuum assist valve which is backed up by abs. drove 500 miles since. no issues. any body experience??
Not the same driving experience, but close on low speed.
Turned out to be the wheel speed sensor. Dealer replaced under warranty. Needed to replace the whole hub.

@Yukon Joe
Drive your raptor here!!!!
www.runraptorrun.com
( * Y * )

Post a pic ofyour Raptor here:
https://r.tapatalk.com/shareLink?url...8&share_type=t
Calendar contest August 17
♤♤♤♤♤♤♤♤♤♤♤♤♤♤♤♤♤♤♤♤

Vote for a pic here: vvvvvvvvvvvv
http://www.fordraptorforum.com/showthread.php?p=1010757


__________________
2012 SCREW | NIGHT RAPTOR Revolution Wrap | RPG Stage 4+, Black Tie-rods, Prerunner 1.0 UCA, Steering Res | AMB LED Light Kit | Raptor Retrofit HIDs w/ Amber Ring | Hefty Fabworks Skid Plates | ADD ABS Guard | Recon 10500lb Winch w/ Factor55 | Whelen LEDs | WSI FE Mount | Extang Solidfold | Weathertech Liners | PDP Flaps | TYT9000VHF Radio |
I love Raptorwifey
Yukon Joe is online now   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake lights stuck on and hill decent message GRI Ford Raptor Problems and Questions Forum 6 06-04-2016 04:45 PM
Hill Descent Control Fault + Brake lights flickering = 3rd Tail Light Leak? BigJ Ford Raptor Problems and Questions Forum 14 03-06-2014 01:01 PM
Hill Descent Control Fault, even after 3rd brake light. Laguna Ford Raptor Problems and Questions Forum 3 11-23-2012 03:13 PM
Who has used hill descent control yet? The Tank Ford SVT Raptor General Discussions [GEN 1] 8 12-04-2010 01:02 AM
Hill descent grinding Falcon Ford SVT Raptor General Discussions [GEN 1] 14 06-29-2010 02:58 PM



GM Truck Forum
Chevy Tahoe Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Tahoe Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Land Rover Forum
Scion FR-S Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum