Go Back   FORD RAPTOR FORUM - Ford SVT Raptor Forums - Ford Raptor > GEN 2 (2017+) Ford F-150 Raptor Forums > Ford Raptor Engine Discussion and Performance Mods - 3.5 Liter EcoBoost V6 [GEN 2]
Become a Supporting Member         Become a Supporting Vendor

Register to remove these ads.


Ford Raptor Engine Discussion and Performance Mods - 3.5 Liter EcoBoost V6 [GEN 2]

Burger Motorsports JB4 tuner install


This is a discussion on Burger Motorsports JB4 tuner install within the Ford Raptor Engine Discussion and Performance Mods - 3.5 Liter EcoBoost V6 [GEN 2] forums, part of the GEN 2 (2017+) Ford F-150 Raptor Forums category!
In case anyone was wondering, the JB4 mobile app for the iPhone costs $27.99....


User Tag List

Like Tree7Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 06-08-2018, 09:13 PM   #11 (permalink)
Full Access Member

 
Join Date: Feb 2017
Posts: 133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default
In case anyone was wondering, the JB4 mobile app for the iPhone costs $27.99.




AKSteve is offline   Reply With Quote
Old 06-08-2018, 09:45 PM   #12 (permalink)
Full Access Member

 
Join Date: Feb 2017
Posts: 133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default
Btw, based on the instructions on Burger Tuning's website versus the pics you posted of your own install, you appear to have installed this backwards. Their website instructions say to install the connector with brown-colored wires to the TMAP sensor at the front of the truck and install the connector with rainbow-colored wires to the MAP sensor at the back of the engine. You did it the opposite way. I have no idea what the ramifications of this are.

Last edited by AKSteve; 06-09-2018 at 12:34 AM.
AKSteve is offline   Reply With Quote
Old 06-09-2018, 04:37 PM   #13 (permalink)
 
halogrinder's Avatar
Full Access Member

 
Join Date: Jun 2017
Age: 36
Posts: 109
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
Originally Posted by AKSteve View Post
Btw, based on the instructions on Burger Tuning's website versus the pics you posted of your own install, you appear to have installed this backwards. Their website instructions say to install the connector with brown-colored wires to the TMAP sensor at the front of the truck and install the connector with rainbow-colored wires to the MAP sensor at the back of the engine. You did it the opposite way. I have no idea what the ramifications of this are.
I explained this in previous posts.
This was a Stg1 beta and upgraded to JB4, so originally it was installed like this, as per instructions. We need to upgrade the firmware and swap the connectors the other way like you mentioned.
halogrinder is offline   Reply With Quote
Old 06-09-2018, 10:41 PM   #14 (permalink)
Full Access Member

 
Join Date: Feb 2017
Posts: 133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default
Oh, guess I missed the explanation. When I'm online, I don't bother to read everything and mostly just look at pics and post snarky comments.

I installed my JB4 this afternoon and it really is easy to do. Put a big can of Torco in and topped the truck off with premium gas and then selected Map 7. Runs awesome but I did have a couple of small backfire bangs in Sport mode when I let off the gas and coasted down in speed. Put the truck back in Normal mode and haven't noticed any further problems so far. Still gonna dial it back to Map 5 or less as a precaution.

Last edited by AKSteve; 06-10-2018 at 01:27 AM.
AKSteve is offline   Reply With Quote
Old 06-10-2018, 01:38 PM   #15 (permalink)
 
halogrinder's Avatar
Full Access Member

 
Join Date: Jun 2017
Age: 36
Posts: 109
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
Originally Posted by AKSteve View Post
Oh, guess I missed the explanation. When I'm online, I don't bother to read everything and mostly just look at pics and post snarky comments.

I installed my JB4 this afternoon and it really is easy to do. Put a big can of Torco in and topped the truck off with premium gas and then selected Map 7. Runs awesome but I did have a couple of small backfire bangs in Sport mode when I let off the gas and coasted down in speed. Put the truck back in Normal mode and haven't noticed any further problems so far. Still gonna dial it back to Map 5 or less as a precaution.
better log it to make sure you're not detonating or something.
halogrinder is offline   Reply With Quote
Old 06-10-2018, 05:55 PM   #16 (permalink)
Full Access Member

 
Join Date: May 2018
Posts: 63
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)

Default
1) this just massages the MAP signals to trick the computer into increasing boost?
2) what does this cost?
3) this can be easily disconnected and the service dept can't detect any evidence of flashing b/c no flashing occurs ever correct?


__________________
2018 Leadfoot SCREW/802A/Techno/moonroof/tailgate step/bed ext/cast wheels/Forscanned/Hellwig sway/RC lights/Dynamat factory sub
eclou is offline   Reply With Quote
Old 06-10-2018, 06:35 PM   #17 (permalink)
 
halogrinder's Avatar
Full Access Member

 
Join Date: Jun 2017
Age: 36
Posts: 109
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
Originally Posted by eclou View Post
1) this just massages the MAP signals to trick the computer into increasing boost?
2) what does this cost?
3) this can be easily disconnected and the service dept can't detect any evidence of flashing b/c no flashing occurs ever correct?


yes
429 plus shipping
yes!
halogrinder is offline   Reply With Quote
Old 06-10-2018, 09:21 PM   #18 (permalink)
 
Ocean18's Avatar
Junior Member

 
Join Date: Mar 2018
Location: Dexter, MI
Age: 33
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default
How do the E20 tunes (Map 7) compare to running E85 or 93 octane?


__________________
2018 Lightning Blue Scab: 802A, Borla S-type, K&N, Shorty Antenna, Black Powdercoated Stockers, Pace-Edwards Ultragroove Tonneau, Thule Pro-rides.

Last edited by Ocean18; 06-10-2018 at 09:24 PM.
Ocean18 is offline   Reply With Quote
Old 06-11-2018, 11:49 AM   #19 (permalink)
 
TXRaptor's Avatar
Full Access Member

 
Join Date: Sep 2010
Posts: 335
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)

Default
This sounds a lot like the Chipwerke mod that a lot of people had problems with previously on our trucks.

Chipwerke for 2017 Ecoboost

The thread starts out with great promise, but then gets worse as more people try it.


__________________
2010 Raptor 6.2L SuperCab - Tuxedo Black, AFE Intake, True Duals w/ MagnaFlow, X-Pipe and Hidden Tailpipes, 5-Star Tunes
Perch Adjustment, 17x8.5 Black Methods, 35x12.50 General Grabber Red Letter, PTM Flares, Bumpers and Door Handles, ADD Race Series Bumper, Vision X LEDs, BakFlip, BedRug
2018 Raptor SuperCrew - Magnetic, 802A, 100% Stock (For now)
TXRaptor is online now   Reply With Quote
Old 06-14-2018, 10:39 AM   #20 (permalink)
 
halogrinder's Avatar
Full Access Member

 
Join Date: Jun 2017
Age: 36
Posts: 109
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
Originally Posted by TXRaptor View Post
This sounds a lot like the Chipwerke mod that a lot of people had problems with previously on our trucks.

Chipwerke for 2017 Ecoboost

The thread starts out with great promise, but then gets worse as more people try it.


JB4/burger tuning has been around for about 10 or so years now, I dont thing its remotely in the same ballpark.

---------- Post added at 09:39 AM ---------- Previous post was at 09:38 AM ----------

Originally Posted by AKSteve View Post
Btw, based on the instructions on Burger Tuning's website versus the pics you posted of your own install, you appear to have installed this backwards. Their website instructions say to install the connector with brown-colored wires to the TMAP sensor at the front of the truck and install the connector with rainbow-colored wires to the MAP sensor at the back of the engine. You did it the opposite way. I have no idea what the ramifications of this are.


The truck came in, we updated the firmware and swapped the connectors. Noticeable difference in driveability difference.
halogrinder is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Livernois Motorsports releases our Gen2 Raptor Tuner! Livernois Motorsports Ford Raptor Engine Discussion and Performance Mods - 3.5 Liter EcoBoost V6 [GEN 2] 29 01-10-2018 12:20 PM
Giant motorsports ddl kit install ntm Ford Raptor Suspension Discussion and Modifications Forum [GEN 1] 96 10-10-2017 10:36 PM
Livernois Motorsports & Engineering MyCal Split Personality tuner Livernois Motorsports Ford Raptor Engine Discussion and Performance Mods-6.2 Liter V8 [GEN 1] 2 03-12-2014 01:34 AM
Introducing the Livernois Motorsports Split Personality Tuner Livernois Motorsports Ford Raptor Engine Discussion and Performance Mods-6.2 Liter V8 [GEN 1] 18 08-20-2013 01:57 AM



GM Truck Forum
Chevy Tahoe Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Tahoe Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Land Rover Forum
Scion FR-S Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum