Go Back   FORD RAPTOR FORUM - Ford SVT Raptor Forums - Ford Raptor > GEN 1 (2010-2014) Ford SVT Raptor Forums > Ford Raptor Engine Discussion and Performance Mods-6.2 Liter V8 [GEN 1]
Become a Supporting Member         Become a Supporting Vendor

Register to remove these ads.


Ford Raptor Engine Discussion and Performance Mods-6.2 Liter V8 [GEN 1]

2011 Raptor - Problem with Whipple Stage II Going Lean


This is a discussion on 2011 Raptor - Problem with Whipple Stage II Going Lean within the Ford Raptor Engine Discussion and Performance Mods-6.2 Liter V8 [GEN 1] forums, part of the GEN 1 (2010-2014) Ford SVT Raptor Forums category!
Hi everyone. Have a 2011 6.2 Raptor that we installed a Stage II Whipple kit on. The truck is currently ...


User Tag List

Sponsored By: GotExhaust
Reply
 
LinkBack Thread Tools Display Modes
Old 12-06-2016, 06:11 PM   #1 (permalink)
Junior Member

 
Join Date: Oct 2016
Posts: 5
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default 2011 Raptor - Problem with Whipple Stage II Going Lean
Hi everyone. Have a 2011 6.2 Raptor that we installed a Stage II Whipple kit on. The truck is currently at the dyno tuner getting a custom tune put on. The tuner called me and stated that the truck is going lean above 3500 rpm. He has tried everything computer-wise, we also swapped the fuel pump and fuel pump driver and still no go. We checked to ensure the correct injectors were installed and they are. I have an email into Whipple but wanted to check here and see if anyone encountered something like this in their trucks.

Thanks




radelow is offline   Reply With Quote
Old 12-06-2016, 10:07 PM   #2 (permalink)
Full Access Member

 
Join Date: May 2016
Location: Pasco, WA
Age: 33
Posts: 187
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)

Default
Whats the fuel pump duty cycle at? Whats the injector duty cycle at?
CarmanKyle is offline   Reply With Quote
Old 12-07-2016, 01:25 PM   #3 (permalink)
 
MTF's Avatar
MTF
FRF Addict

 
Join Date: Nov 2010
Location: NYC
Age: 57
Posts: 3,398
Mentioned: 81 Post(s)
Tagged: 0 Thread(s)

Default
Going lean can be caused by quite a few mechanical issues.

Fuel pump would not be an issue, even with the Stage 2
While I did upgrade my fuel pump, it turns out it's not really necessary unless you're going beyond the stock Whipple Stage 2 setup with Whipple's Tune.

1) O-rings on the manifold is the number one cause.
2) Vacuum leaks from any of the hoses and hose connection.
3) O2 sensors

A complete fuel TRIM reading is the only way to tell. Whipple will want that info as well!
Did the Tuner say which bank or is it both 1 and 2

Keep us updated.

P.S. You may want to check the fuse 27 issue


---------- Post added at 01:25 PM ---------- Previous post was at 01:21 PM ----------

Originally Posted by CarmanKyle View Post
Whats the fuel pump duty cycle at? Whats the injector duty cycle at?
Duty cycle is not the way to determine fuel flow on these trucks.
Fuel rail pressure is the correct way.


__________________
Whipple 700+ HP 800+ in the works, Oil and Fuel pump upgrades, Custom Deavers +2 Rear Springs, Axle Exchange Driveshaft, Rogue Racing Traction Bars, Hellwig rear sway bar, Pace Edward electric bed cover with remote, Pop & Lock Tail Gate lock, Mud Flaps, Window Rain Guards, EZ Down Tailgate, Bed Rug,
Future Installs: Brembo Brakes 15" Gran Turismo

Last edited by MTF; 12-07-2016 at 01:34 PM.
MTF is offline   Reply With Quote
Old 12-12-2016, 02:05 AM   #4 (permalink)
Junior Member

 
Join Date: Oct 2016
Posts: 5
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
Hi everyone. We ended up swapping out both the fuel pump and the driver module and everything tuned up correctly. Strange that they were partially broken (one or both)... Anyway truck runs perfect and is a complete BEAST.

Thanks!
radelow is offline   Reply With Quote
Old 12-29-2016, 11:17 AM   #5 (permalink)
 
5150_Raptor's Avatar
Junior Member

 
Join Date: Oct 2016
Age: 33
Posts: 16
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)

Default
Sounds like you need to run a bap

Sent from my SM-G930V using Tapatalk
5150_Raptor is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Raptor Lean accely Ford Raptor Problems and Questions Forum 158 10-09-2017 03:58 PM
2011 Camaro SS Whipple, and much more.. cpetes Vehicles For Sale 2 05-26-2016 06:20 PM
Thinking about mounting a Stage 2 Whipple kit, looking for information. ivo1.cox Ford Raptor Engine Discussion and Performance Mods-6.2 Liter V8 [GEN 1] 10 09-01-2015 04:40 PM
2011 SVT Raptor Gearshifting problem sean ralph Ford Raptor Problems and Questions Forum 1 11-16-2014 10:45 AM
Livernois Built 2011 Raptor - Whipple 2.9 & Livernois Cams - VIDEO Livernois Motorsports Livernois Motorsports 29 02-24-2014 08:54 AM



GM Truck Forum
Chevy Tahoe Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Tahoe Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Land Rover Forum
Scion FR-S Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum