Go Back   FORD RAPTOR FORUM - Ford SVT Raptor Forums - Ford Raptor > Ford Raptor Tech Forums > 2013 Ford SVT Raptor Forum (Reply Only)
Become a Supporting Member         Become a Supporting Vendor

Register to remove these ads.


2013 Ford SVT Raptor Forum (Reply Only)

New '13 Raptor


This is a discussion on New '13 Raptor within the 2013 Ford SVT Raptor Forum (Reply Only) forums, part of the Ford Raptor Tech Forums category!
So, first post. I finally pulled the trigger and traded my F250 V10 King Ranch for a 2013 Raptor. Gonna ...


User Tag List

Like Tree5Likes

Reply
 
LinkBack Thread Tools Display Modes
Old 01-26-2014, 08:01 PM   #1 (permalink)
Junior Member

 
Join Date: Jan 2014
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default New '13 Raptor
So, first post. I finally pulled the trigger and traded my F250 V10 King Ranch for a 2013 Raptor. Gonna miss the big truck, but, just don't have a need for the brute anymore.

I had not even considered the Raptor until I traveled with a friend to Arkansas for duck hunting after Christmas. Yes the gas mileage is horrendous, but, coming from the V10, I've learned not worry about the gas and just enjoy the ride :) What impressed me the most was the smooth highway ride and its off-road capability.

I have a couple of quick questions - 1. The low tire pressure light came on about 15 miles after the purchase and I can't get it to go out. Checked the tire pressure in all four tires and pumped them up to 48psi (all were around 44psi). Then thought that it might be the spare. Although it was fine, pumped it up to 48psi. I know that this is a little high, but, the sidewall says the tire can handle 50psi under max load so I think I'll be ok. Any suggestions on what might be the problem? 2. What does everyone have for a wheel on their spare? Mine is the standard Raptor Wheel. Is that normal to have a spare wheel that is different from the bead locks?

Thanks in advance for the help! ...and I know, no pics and it never happened.




atl fahrer is offline   Reply With Quote
Old 01-26-2014, 08:47 PM   #2 (permalink)
 
Rookie's Avatar
FRF Addict


 
Join Date: Dec 2012
Location: Fort Wayne, IN
Posts: 9,752
Mentioned: 355 Post(s)
Tagged: 5 Thread(s)

Default
Hello and congrats. The recommendation from Ford is 44psi. There might be a bad tpms. You could try disconnecting the battery and seeing if it resets. Otherwise I'd turn back around and let the dealer fix it.
Rookie is offline   Reply With Quote
Old 01-26-2014, 09:15 PM   #3 (permalink)
 
banman12's Avatar
Full Access Member

 
Join Date: Jan 2013
Location: Rochester, NY
Age: 28
Posts: 428
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default
The sensors should not be coming on unless a tire is dropping below 38-40 PSI. Probably a bad sensor, take to the dealer if it doesn't turn off.
sonoma likes this.


__________________
Tuxedo Black SCAB:
Ordered 1/5/13 at invoice
Build date - 3/26/13
Picked up - 4/18/13
banman12 is offline   Reply With Quote
Old 01-27-2014, 10:15 PM   #4 (permalink)
Junior Member

 
Join Date: Jan 2014
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
Thanks for the replies, everyone. Took the truck back to the dealer today and they reset the system. All is well.
atl fahrer is offline   Reply With Quote
Old 01-28-2014, 12:58 AM   #5 (permalink)
 
BearLeeAsian's Avatar
FRF Addict

 
Join Date: Oct 2013
Location: Dallas Texas
Posts: 3,401
Mentioned: 119 Post(s)
Tagged: 0 Thread(s)

Default
Weird they gave you a standard wheel when yours came with beadlocks.. Then again, mine didn't. I would think the spare would be beadlocks too...


__________________
12 Hennessey Velociraptor 600
BearLeeAsian is offline   Reply With Quote
Old 01-29-2014, 08:49 AM   #6 (permalink)
 
Battlefront's Avatar
Full Access Member

 
Join Date: Apr 2013
Location: Orange Co. NY
Age: 52
Posts: 351
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)

Default
Your truck should have came with a Beadlock rim spare. Even though I knew what I had you had me doubting myself for a second so I just went out to the garage and checked before I posted. I remember reading that somewhere when I was still researching my truck before I ordered. I don't remember where but I thought it was on the Ford website among other places.
I would check with the dealer on that one. You should have the beadlock rim spare if you ordered the beadlock rim option.
Welcome aboard by the way!!
Jimster58 likes this.


__________________
2013 Screw Tuxedo Black,Mid Perch, Corsa Xtreme cat back exhaust, VisionX Light cannons on SDHQ mounts,JLT oil seperator. BakFlip F1, PDP mud flaps

Last edited by Battlefront; 01-29-2014 at 08:53 AM.
Battlefront is offline   Reply With Quote
Old 01-29-2014, 09:33 AM   #7 (permalink)
 
Witchy's Avatar
FRF Lady

 
Join Date: Jun 2013
Location: Longmont, CO
Age: 46
Posts: 6,801
Mentioned: 164 Post(s)
Tagged: 4 Thread(s)

Default
Welcome! Our 13 came with beadlocks and beadlock spare. We also were able to purchase a second beadlock spare. I'd head back to the dealer!


Sent from my iPhone using Tapatalk
Witchy is offline   Reply With Quote
Old 01-29-2014, 01:59 PM   #8 (permalink)
Junior Member

 
Join Date: Jan 2014
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

(Thread Starter)
Default
Thanks, everyone. I thought the rims were supposed to match. As soon as we thaw out of this mess in Atlanta, I'll get back up to the dealer and, hopefully, get it taken car of.

In the meantime, some snow pics...
Attached Thumbnails
front.jpg   snow1.jpg   snow2.jpg  

atl fahrer is offline   Reply With Quote
Old 01-29-2014, 03:23 PM   #9 (permalink)
 
MotuMute's Avatar
Senior Member

 
Join Date: Jan 2012
Location: Dallas, TX
Posts: 4,835
Mentioned: 5 Post(s)
Tagged: 1 Thread(s)

Default
Welcome & Good Luck!
MotuMute is offline   Reply With Quote
Old 01-29-2014, 04:09 PM   #10 (permalink)
 
RaptorWifey's Avatar
FRF Lady


 
Join Date: Mar 2012
Location: Oak Island NC
Age: 35
Posts: 5,149
Mentioned: 230 Post(s)
Tagged: 8 Thread(s)

Default
to the forum!


__________________
RaptorWifey is offline   Reply With Quote
Reply

Bookmarks


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




GM Truck Forum
Chevy Tahoe Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Tahoe Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Land Rover Forum
Scion FR-S Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum